Change DE from Cinnamon to DE Plasma safely

Hi, I have Cinnamon but just saw a demo KDE Plasma and really like what I have read and seen about it. Can you point me to a tutorial on how to change safely without breaking Manjaro? Is it the case I need to boot to a USB in order to change the DE? If so how do I do that. Or is it better to download Manjaro with KDE and start over. I have only used Manjaro for a few days, but I have made some Cinnamon customisations. Thanks.

The ‘safest’ is really a new install.

But you can use something like this

and/or maybe this (it was made for kde recovery …I make no promises):
recover-kde-manjaro ($1996897) · Snippets · Snippets · GitLab

You can also try to install KDE Plasma in your current installation keeping Cinnamon
You can also try to install all different DE as much as you want
You can even try mixing Qt and Gtk in one session
All runs quite well and normally

I know some high skilled not recommand that, but i always install many different DE on all distros i tried and actually in Manjaro wich is goaled to during a marathon, never had any issues with several DE mixing except sometimes a changing theme wich is resolved in three clicks

Before a re-install, let’s try, why re-install when no need ?

1 Like

Maybe you missed the part where both links are install alongside instructions …

Maybe, i’m not sure, do you mean thtat?

The Risks of Using Multiple DEs
Installing multiple DEs is not without risks. Here are some things that can pop-up when running more than one DE:

    The settings packages overlap so you can only have one DE pre-configured with the Manjaro theming. The others will need to have the theming applied manually.
    You can end up with more than one instance of similar applications. For example, it is common to end up with 2 Bluetooth managers. It takes some tweaking to get a single manager working in multiple DEs
    Sometimes two different DEs will share the same configuration files causing strange things to happen, especially with theming

These risks are greatly reduced by using a different user account for each DE.

In summary, running multiple DEs is possible and a great way to enjoy Manjaro but it requires a willingness to troubleshoot and work through minor problems. If you are the type of person who wants everything to "just work" out of the box, running multiple DEs might not be for you. 


Well that section exist on the page … but my link goes directly to the ‘install kde’ section
(which is of course one of many other sections that inculde instructions on installing DE’s…)

Point is … while you guessed correctly that I wouldnt exactly encourage it … what I had done was provide instructions on how to install, as was asked, so it was a bit odd for you to react as if I had rejected the idea.

(…) so it was a bit odd for you to react as if I had rejected the idea.

Calm down dude, i was just responsing to ms971 and nothing else, , i’m not here to play who has the biggest to piss the farewest, i’m not concerned by your ego perturbation

Well you sure are confusing. Maybe its a language thing.
But uh … all the best to you I guess? :smiley_cat:

1 Like

So I tried that by downloading Manjaro-kde iso and installed it on a USB. It installs with a strange error: Installation failed. Boost.Python error in job “grubcfg”
<class ‘OSError’>
[Errno 30] Read-only file system ‘/tmp/calamares-root-srt76j0x/etc/default/grub’

Traceback, etc etc.

It seems to work, but how to confirm all the files are correct?

Also, I suspect the grubcfg may have something to do with me creating a grub bootloader in BIOS and deleting it through gparted when I created it through Windows. Now I can only boot the laptop in legacy BIOS mode. This all started when I decided Windows 10 has to go, but my wife still wanted it so I did a dual boot with Ubuntu, which I have grown to dislike intensely.

All I really want is a clean Manjaro with KDE booting in UEFI like was before I started changing the boot in bios. Also this Manjaro with KDE does not see the wifi connection even though it says NetworkManager is installed and the open source bluez does not give me bluetooth. This is the only reason I decided to put Cinnamon on, because it sees the wifi automatically, but still not the bluetooth, which I can learn to live without or get a USB one.

Thanks for all your immediate responses and willingness to help. It looks like an awesome community and I do not plan on moving away from Manjaro with KDE Plasma once it is working, as this is what I call the ultimate combination for me.

Interestingly I also tried to use the Anarchy installer and it crashed with a page of errors. And I tried with Arch and crashed into cli halfway through the install with another cryptic page of errors.

I hope not to have given you too many things to resolve but I really want KDE with wifi.

The laptop is a Acer Aspire E15 ES1-571-30T2 from around 2016.


I have read so many warnings about overlapping packages, so I will try on a USB.

I did the fresh install with KDE as you suggested.
Its fine except it cannot see wifi, so I have to use ethernet. I cannot install a wireless printer thru CUPS, but I am sure they will get ironed out over time.
It really is an awesome build. Thanks for your help.

Now that you have this new system, and at least wired connection … please open a new thread with your new issue(s), making sure to see this first:

I managed to get wireless driver installed. As a longtime Mac user with Homebrew, I know quite a bit about Linux. But nothing could have prepared me for the sheer amount of time I invested in resolving what should have been a simple well documented issue of not having the right packages downloaded to detect wireless connections. I will create a separate thread on this if anyone is interested in the experience.

Hey, if you make a new post you should explain this one and how could this one happen. I downloaded the KDE Manjaro ISO and installed it and both, live USB and after install prompted me for Wi-Fi connection to the network and both worked. I have the TP-LINK W7200ND which has a lot of posts from some years ago not working properly, specially on Laptops because of the in built wifi cards. Could it be that the device you have wasn’t recognized or something? I’m a Linux noob, I just feel that if you download the ISO and fresh install all the packages should be there. Or could it be something of not connecting to the internet during installation?
Edit: Not working properly on Linux, mostly Ubuntu posts. I didn’t mean Manjaro specifically.

Get a minimal window manager, uninstall cinnamon and then install KDE? I don’t see anything risky with that method, and no need to do an entirely new install for literally just a DE.

I just followed the Archwiki – amazing resource. Everything works fine now.