CH340 devices are not being recognized

CH340 drivers should be preinstalled in the kernel but for some reason none of the CH340 micro-controllers are being detected in Manjaro kernel 5.10 or 5.14.

Are you perhaps having the issue discussed here?

2 Likes

I dont think that is the issue as my ch340 device was not even getting recognized as a device plugged in, anyways I fixed it by switching to kernel version 5.10 from 5.14 and then building the drivers myself, I had to go to the older kernel because for some reason the build was failing on the newer kernels.

In fact, I try to switch 5.10 from 5.13. The result told me that it is not because the kernel. As you can see, the driver of ch341 exist in both kernel.

$ ls /lib/modules/5.13.19-2-MANJARO/kernel/drivers/usb/serial
aircable.ko.xz         iuu_phoenix.ko.xz  quatech2.ko.xz
ark3116.ko.xz          keyspan.ko.xz      safe_serial.ko.xz
belkin_sa.ko.xz        keyspan_pda.ko.xz  sierra.ko.xz
ch341.ko.xz            kl5kusb105.ko.xz   spcp8x5.ko.xz
cp210x.ko.xz           kobil_sct.ko.xz    ssu100.ko.xz
cyberjack.ko.xz        mct_u232.ko.xz     symbolserial.ko.xz
cypress_m8.ko.xz       metro-usb.ko.xz    ti_usb_3410_5052.ko.xz
digi_acceleport.ko.xz  mos7720.ko.xz      upd78f0730.ko.xz
empeg.ko.xz            mos7840.ko.xz      usb_debug.ko.xz
f81232.ko.xz           mxuport.ko.xz      usb-serial-simple.ko.xz
f81534.ko.xz           navman.ko.xz       usb_wwan.ko.xz
ftdi_sio.ko.xz         omninet.ko.xz      visor.ko.xz
garmin_gps.ko.xz       opticon.ko.xz      whiteheat.ko.xz
io_edgeport.ko.xz      option.ko.xz       wishbone-serial.ko.xz
io_ti.ko.xz            oti6858.ko.xz      xr_serial.ko.xz
ipaq.ko.xz             pl2303.ko.xz       xsens_mt.ko.xz
ipw.ko.xz              qcaux.ko.xz
ir-usb.ko.xz           qcserial.ko.xz


$ ls /lib/modules/5.10.70-1-MANJARO/kernel/drivers/usb/serial/
aircable.ko.xz         ir-usb.ko.xz       qcaux.ko.xz
ark3116.ko.xz          iuu_phoenix.ko.xz  qcserial.ko.xz
belkin_sa.ko.xz        keyspan.ko.xz      quatech2.ko.xz
ch341.ko.xz            keyspan_pda.ko.xz  safe_serial.ko.xz
cp210x.ko.xz           kl5kusb105.ko.xz   sierra.ko.xz
cyberjack.ko.xz        kobil_sct.ko.xz    spcp8x5.ko.xz
cypress_m8.ko.xz       mct_u232.ko.xz     ssu100.ko.xz
digi_acceleport.ko.xz  metro-usb.ko.xz    symbolserial.ko.xz
empeg.ko.xz            mos7720.ko.xz      ti_usb_3410_5052.ko.xz
f81232.ko.xz           mos7840.ko.xz      upd78f0730.ko.xz
f81534.ko.xz           mxuport.ko.xz      usb_debug.ko.xz
ftdi_sio.ko.xz         navman.ko.xz       usb-serial-simple.ko.xz
garmin_gps.ko.xz       omninet.ko.xz      usb_wwan.ko.xz
io_edgeport.ko.xz      opticon.ko.xz      visor.ko.xz
io_ti.ko.xz            option.ko.xz       whiteheat.ko.xz
ipaq.ko.xz             oti6858.ko.xz      wishbone-serial.ko.xz
ipw.ko.xz              pl2303.ko.xz       xsens_mt.ko.xz

In conclusion, I remove brltty package as @iracigt recommend and it work out.

Worked for me.

Thanks.