Certain keys only working after hitting ALT key

Dear All.

First, my system info:

  Kernel: 5.10.114-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=befa46fa-af6a-4e1b-812b-f4986fb67877 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20CK003HMD v: ThinkPad T550
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20CK003HMD v: SDK0J40705 WIN
    serial: <superuser required> UEFI: LENOVO v: N11ET54W (1.30 )
    date: 09/01/2021
  ID-1: BAT0 charge: 35.1 Wh (100.0%) condition: 35.1/44.4 Wh (79.0%)
    volts: 12.8 min: 11.2 model: SANYO 45N1741 type: Li-poly serial: <filter>
    status: full
  ID-2: BAT1 charge: 17.8 Wh (100.0%) condition: 17.8/23.5 Wh (75.9%)
    volts: 12.6 min: 11.4 model: LGC 45N1127 type: Li-ion serial: <filter>
    status: full
  RAM: total: 15.51 GiB used: 2.97 GiB (19.1%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1606 high: 2197 min/max: 500/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2197 2: 798 3: 1234
    4: 2195 bogomips: 17566
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    avx avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt
    xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
    ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:1616 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 2-8:7 chip-ID: 04f2:b449 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x35ed built: 2013 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 22.0.3
    direct render: Yes
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Sound Server-1: ALSA v: k5.10.114-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Ethernet I218-V vendor: Lenovo driver: e1000e v: kernel
    port: 3080 bus-ID: 00:19.0 chip-ID: 8086:15a3 class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:095b class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 2-7:6 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 238.47 GiB used: 109.83 GiB (46.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD PM851 2.5 7mm 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 8D0Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%)
    used: 109.83 GiB (47.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: befa46fa-af6a-4e1b-812b-f4986fb67877
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 29DA-2764
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s
    chip-ID: 8087:8001 class-ID: 0900
  Hub-3: 2-0:1 info: Hi-speed hub with single TT ports: 11 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-3:2 info: Apple Keyboard Hub ports: 3 rev: 2.0 speed: 480 Mb/s
    power: 300mA chip-ID: 05ac:1005 class-ID: 0900
  Device-1: 2-3.2:4 info: Apple Aluminum Mini Keyboard (ISO)
    type: Keyboard,HID driver: apple,usbhid interfaces: 2 rev: 2.0
    speed: 1.5 Mb/s power: 20mA chip-ID: 05ac:021e class-ID: 0300
  Device-2: 2-5:3 info: Alcor Micro AU9540 Smartcard Reader type: Smart Card
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 50mA
    chip-ID: 058f:9540 class-ID: 0b00
  Device-3: 2-6:5 info: Validity Sensors VFS 5011 fingerprint sensor
    type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 138a:0017 class-ID: ff00 serial: <filter>
  Device-4: 2-7:6 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2a class-ID: e001
  Device-5: 2-8:7 info: Chicony Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b449 class-ID: 0e02 serial: <filter>
  Hub-5: 3-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 40.0 C pch: 38.0 C mobo: 0.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 217 Uptime: 7m wakeups: 2 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1602 pacman: 1585 lib: 443
  flatpak: 5 snap: 12 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.15

I am on the brink of going nuts because certain keys are not working properly. The keys in question: g, h, ø and the up-arrow. The weird thing, though, is that they do work for some 5 seconds if - and only if - I first hit the Alt-key (which allows me to write this). It’s only this key that somehow allows those keys to work for some few seconds.

I have searched and searched, but not found a solution. System is updated. I have tried to switch kernel. Also, in time this new dysfunction seems to me to have come about after I switched from 510 to 515. After switching back to 510 this issue is not resolved, though.

Here some more info:

sudo dmesg | less

4e1b-812b-f4986fb67877 rw quiet apparmor=1 security=apparmor udev.log_priority=3
[    0.000000] x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
[    0.000000] x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
[    0.000000] x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using 'standard' format.
[    0.000000] BIOS-provided physical RAM map:
[    0.000000] BIOS-e820: [mem 0x0000000000000000-0x0000000000057fff] usable
[    0.000000] BIOS-e820: [mem 0x0000000000058000-0x0000000000058fff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000000059000-0x000000000009bfff] usable
[    0.000000] BIOS-e820: [mem 0x000000000009c000-0x000000000009cfff] reserved
[    0.000000] BIOS-e820: [mem 0x000000000009d000-0x000000000009dfff] usable
[    0.000000] BIOS-e820: [mem 0x000000000009e000-0x000000000009ffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000000100000-0x00000000ca762fff] usable
[    0.000000] BIOS-e820: [mem 0x00000000ca763000-0x00000000ca962fff] type 20
[    0.000000] BIOS-e820: [mem 0x00000000ca963000-0x00000000ccbfefff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000ccbff000-0x00000000ccd7efff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000ccd7f000-0x00000000ccdfefff] ACPI data
[    0.000000] BIOS-e820: [mem 0x00000000ccdff000-0x00000000ccdfffff] usable
[    0.000000] BIOS-e820: [mem 0x00000000f80f8000-0x00000000f80f8fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed1c000-0x00000000fed1ffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000100000000-0x000000042dffffff] usable
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] efi: EFI v2.31 by Lenovo
[    0.000000] efi: ACPI=0xccdfe000 ACPI 2.0=0xccdfe014 SMBIOS=0xccbfe000 ESRT=0xca9c4000 
[    0.000000] SMBIOS 2.7 present.
[    0.000000] DMI: LENOVO 20CK003HMD/20CK003HMD, BIOS N11ET54W (1.30 ) 09/01/2021
[    0.000000] tsc: Fast TSC calibration using PIT
[    0.000000] tsc: Detected 2194.917 MHz processor
[    0.000089] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[    0.000093] e820: remove [mem 0x000a0000-0x000fffff] usable
[    0.000099] last_pfn = 0x42e000 max_arch_pfn = 0x400000000
[    0.000104] MTRR default type: write-back
[    0.000105] MTRR fixed ranges enabled:
[    0.000106]   00000-9FFFF write-back
[    0.000108]   A0000-BFFFF uncachable
[    0.000109]   C0000-FFFFF write-protect
[    0.000110] MTRR variable ranges enabled:
[    0.000111]   0 base 00E0000000 mask 7FF0000000 uncachable
[    0.000113]   1 base 00D0000000 mask 7FF0000000 uncachable
[    0.000114]   2 base 00CE000000 mask 7FFE000000 uncachable
[    0.000115]   3 base 00CD000000 mask 7FFF000000 uncachable
[    0.000116]   4 base 00CCE00000 mask 7FFFE00000 uncachable
[    0.000117]   5 base 00F0000000 mask 7FF0000000 uncachable
[    0.000118]   6 disabled

Output for

sudo dmesg --level emerg,alert,crit,err,warn

[    0.148632] DMAR: [Firmware Bug]: No firmware reserved region can cover this RMRR [0x00000000cd800000-0x00000000cfffffff], contact BIOS vendor for fixes
[    0.148633] DMAR: [Firmware Bug]: Your BIOS is broken; bad RMRR [0x00000000cd800000-0x00000000cfffffff]
               BIOS vendor: LENOVO; Ver: N11ET54W (1.30 ); Product Version: ThinkPad T550
[    0.175308] MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.
[    0.175458]  #2 #3
[    0.183191] ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
[    0.218154] ACPI Error: Needed type [Reference], found [Integer] 00000000992d2c0a (20200925/exresop-66)
[    0.218160] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20200925/dswexec-431)
[    0.218165] ACPI Error: Aborting method \_PR.CPU0._PDC due to previous error (AE_AML_OPERAND_TYPE) (20200925/psparse-529)
[    0.759407] ata1.00: NCQ Send/Recv Log not supported
[    0.761478] ata1.00: NCQ Send/Recv Log not supported
[    2.977624] vboxdrv: loading out-of-tree module taints kernel.
[    3.034880] VBoxNetAdp: Successfully started.
[    3.045454] VBoxNetFlt: Successfully started.
[    4.459799] acpi PNP0C14:01: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:00)
[    4.459941] acpi PNP0C14:02: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:00)
[    4.960460] iwlwifi: unknown parameter '#' ignored
[    4.960463] iwlwifi: unknown parameter 'enables' ignored
[    4.960465] iwlwifi: unknown parameter 'software' ignored
[    4.960467] iwlwifi: unknown parameter 'crypto' ignored
[    4.960469] iwlwifi: unknown parameter '#' ignored
[    4.960471] iwlwifi: unknown parameter 'disables' ignored
[    4.960472] iwlwifi: unknown parameter 'power' ignored
[    4.960474] iwlwifi: unknown parameter 'management' ignored
[    4.960476] iwlwifi: unknown parameter '#' ignored
[    4.960478] iwlwifi: unknown parameter 'disables' ignored
[    4.960479] iwlwifi: unknown parameter '11n' ignored
[    4.960481] iwlwifi: unknown parameter 'connections' ignored
[    4.960483] iwlwifi: unknown parameter '#' ignored
[    4.960484] iwlwifi: unknown parameter 'disables' ignored
[    4.960486] iwlwifi: unknown parameter '11ac' ignored
[    4.960488] iwlwifi: unknown parameter 'connections' ignored
[    4.960489] iwlwifi: unknown parameter '#' ignored
[    4.960491] iwlwifi: unknown parameter 'disables' ignored
[    4.960492] iwlwifi: unknown parameter '11ax' ignored
[    4.960494] iwlwifi: unknown parameter 'connections' ignored
[    5.294912] kauditd_printk_skb: 35 callbacks suppressed
[    5.332540] at24 0-0050: supply vcc not found, using dummy regulator
[    5.336220] at24 0-0051: supply vcc not found, using dummy regulator
[    5.425473] iwlwifi 0000:03:00.0: iwlmvm doesn't allow to disable HW crypto, check swcrypto module parameter
[    5.426077] thermal thermal_zone2: failed to read out thermal zone (-61)
[    8.266465] Bluetooth: hci0: unexpected event for opcode 0xfc2f
[    8.776723] ACPI: \: failed to evaluate _DSM (0x1001)
[    8.776725] ACPI: \: failed to evaluate _DSM (0x1001)
[    8.897805] ACPI: \: failed to evaluate _DSM (0x1001)
[    8.897808] ACPI: \: failed to evaluate _DSM (0x1001)
[   12.194221] kauditd_printk_skb: 28 callbacks suppressed
[   18.469258] kauditd_printk_skb: 7 callbacks suppressed
[   34.937315] kauditd_printk_skb: 10 callbacks suppressed

That looked depressing.

Thanks for reading. Are there some wizards around to help me out?

Maybe related to this Lenovo ThinkPad T550 - ArchWiki
but you mentioned Alt … so did you change the way Fn keys are activated?

1 Like

Hi and thanks!

It was turned off actually. I know for a fact that some days ago it was on. Well, I turned it on again. Somehow the problem keys worked for a minute or so. Thus some kind of progress. Eventually though they revert back to dysfunction.

I just bought this laptop. Shouldn’t be dirt, but I will try and see if there actually is dirt under those keys. I have before made use of a vacuum cleaner. I will try more of this while awaiting more responses, thank you.

I doubt that … one thing worth to check if using a different keyboard layout is the variant, as it can make it act differently.

Usually, I don’t like this but you could test different distributions or even Windows PE (look for Hiren’s boot cd) if it’s specific.

Keyboards are prone to errors, so my first guess would be actual hardware errors.

As a quick test, do you maybe have the numpad activated?

So I have tried different keyboard layouts. I have also tested an external keyboard, sorry to forget to tell, but that worked perfect.

I have used the keyboard layout I found closest to my actual system: IBM ThinkPad 560Z/600/600E/A22E. Using other layouts has not helped thus far, but I guess I can try them all of them, one by one.

And, as I type here, it seems that those problem keys are working for much, much loner now, though not fully stable. For instance if a key doesn’t react to my prompt it will somehow work if I press the key for longer.

Which leads to, I guess, this question: will it take some time before the switching on of the Fn-key will take full effect?

It wasn’t turned on. I switched on and off, but this had no effect on those keys.

What baffles me is just how it is possible for those keys to work only after I hit that Alt-key. If they aren’t working, why would Alt have them work for some few seconds?

The lines on a keyboard are thin. I could build up metaphors like traffic jams but I guess that’s not really representative of what’s actually going on in electronics.

You should test the keyboard in different operating systems like I mentioned before. Does it work in UEFI/Bios (at lest the arrow key can be tested easily). And what is the empty set button?

I have tested also in UEFI/Bios - and the up-arrow key didn’t work there either.

But it does work in a terminal (I don’t know its name) I can access via Ctrl+Alt+F3. How’s that possible?


Thank you all for your kind help. Now the keys seem to work properly again. I cannot be 100% sure, but I think the issue was related to the X server. Post here.

I have found that after killing the X server with the key combination

Ctrl + Alt + Backspace
my problem keys now work like a charm again!

At least thus far. I will wait a couple of hours until I close this subject, thanks you!


I close the thread because the issue now definitely seems resolved. Keys are working as they should. Killing the X server MIGHT have been the solution.

Still, I did experience lapses where keys reverted to non-responsiveness.

I also did another adjustment yesterday, though, after which and ever since the keys have worked flawlessly. Some months ago my daughter “watered” my laptop. I bought a new one and had the shop transfer my entire system to the new laptop. I noticed that the old host name was also present in my new laptop.

So I did the procedure described here:

After that everything worked as it should.

Thank you for your kind attention. Regards, R.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.