CD burner write permissions

Hi. brasero and k3b wont run because the cd drive is read only. How to give the drive write permissions ? Strange that a cd burner is read only.
Please DONT link me help for k3b or brasero, I want the burner available for any programme.

Welcome to the forum! :slight_smile:

If you have a CD or DVD in the drive that already contains data, and you have mounted that disk ─ for instance, in order to browse the contents ─ then you cannot write to the disk, unless it was explicitly mounted as a DVD-RAM.

That said, if the above does not apply, click up a terminal and issue the following command… :arrow_down:

id | grep optical

If the above command does not provide any output, then you need to add your user account ─ I am assuming that it’s damod11, but change this to your actual login name ─to the optical group, as follows… :arrow_down:

sudo usermod -a damod11 -G optical

You’ll need to log out and log back in for the changes to take effect.

1 Like

it worked BEFORE i logged out. After restart its back to /dev/sr0 (Read-Only)

[kdf-pc@kdf-hp ~]$ id | grep optical
uid=1000(kdf-pc) gid=1000(kdf-pc) groups=1000(kdf-pc),3(sys),90(network),98(power),108(vboxusers),990(optical),991(lp),998(wheel)

Okay, then let’s try the following…

Click on the Settings menu, choose “Configure K3b”, and select the Programs section. Then click on the Permissions tab. You can change the permissions of individual programs there.

If the solution from @Aragorn fails (as k3B did for me…):

The required rights and group membership can be set with the following commands.
sudo chmod 4710 /usr/bin/cdrdao
sudo chmod 4710 /usr/bin/cdrecord
sudo chmod 0750 /usr/bin/growisofs

sudo chmod 4710 /usr/sbin/cdrdao
sudo chmod 4710 /usr/sbin/cdrecord
sudo chmod 0750 /usr/sbin/growisofs

sudo chmod 4710 /sbin/cdrdao
sudo chmod 4710 /sbin/cdrecord
sudo chmod 750 /sbin/growisofs

sudo chown root:optical /usr/bin/cdrecord
sudo chown root:optical /usr/bin/cdrdao
sudo chown root:optical /usr/bin/growisofs

Finaly add your user to GROUP optical:
[[sudo usermod -g optical <MyUserName> ]] the below is the most accurate (thanks @Aragorn)
sudo usermod -a <MyUserName> -G optical

After these measures, k3B worked pretty fine again for me.
(credits for the solution go to K3b can’t burn ISO image )

1 Like

K3b settings wont open. Some dameon error

This is not correct. This would make the group optical the primary user group for that user. The correct command should be… :arrow_down:

sudo usermod -a your_user_name -G optical

:wink:

1 Like

Ive uninstalled k3b. Now how to make my cd burner work ?

Have you done what @b_quest told you to do? :arrow_down:

No. K3b settings not working

He didn’t tell you to do it via the K3b settings. What he listed are commands that must be issued in a terminal window.

Thanks! I corrected my posting above to have all of the good solution in one …

Another reason to install the package lxqt-admin-user … now that kuser became abandoned.
A nice GUI gives you the overview and the control over what you are about to do and what you have done :slight_smile:

1 Like

Usually, the program is throwing some error messages at our heads (if it does not from the GUI right away, then please start k3b from the command line, the errors may get posted there then).