Catfish file search is not working since stable update on 2021-07-28

OS: Manjaro XFCE Stable branch

Catfish does not run, and when I run catfish in the terminal, I get the following error message

$ catfish
Traceback (most recent call last):
  File "/usr/bin/catfish", line 44, in <module>
  File "/usr/lib/python3.9/site-packages/catfish/", line 78, in main
    window = CatfishWindow.CatfishWindow()
  File "/usr/lib/python3.9/site-packages/catfish_lib/", line 173, in __new__
    builder = get_builder(__builder__['ui_file'])
  File "/usr/lib/python3.9/site-packages/catfish_lib/", line 87, in get_builder
    ui_filename = get_data_file('ui', '%s.ui' % (builder_file_name,))
  File "/usr/lib/python3.9/site-packages/catfish_lib/", line 50, in get_data_file
    return os.path.join(get_data_path(), *path_segments)
  File "/usr/lib/python3.9/site-packages/catfish_lib/", line 67, in get_data_path
    raise project_path_not_found

A different issue was posted here.

Related Arch Bug: FS#71600 : [catfish] fails to launch

Workaround from the Arch bug tracker:

can be worked around by editing /usr/lib/python3.9/site-packages/catfish_lib/ line 30 to say:
catfish_data_directory = "/usr/share/catfish’

Can this package be downgraded in the official repositories for the stable branch, because catfish is an important component of the XFCE desktop for file search?

Fixed via 4.16.1-1.0


I didnt receive an update
All mirrors are partially or fully out of date:

I received the update. Thanks

Hi guys,
I have 4.16.1-1 and I still have the issue

editing the config file, catfish works in terminal and Thunar now, but doesn’t launch from (XFCE) applications menu

You need the version 4.16.1-1.0. Now it works for me, from the terminal, from thunar, and from whisker menu.

The config file was already edited in this version.

In case you still have not received this version as an update, wait for the mirrors to sync, or change your mirror.

really weird, as of now I can still only see 4.16.1-1

I’m on the stable-staging branch, I feel like some packages from stable don’t get released to the staging branch?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.