Caps Lock/Hyper behavior very inconsistent

I’ve been trying to solve this for weeks now. Before I switched to Linux, I had wired AutoHotkey to replace the function of the Caps Lock key to become a modifier (e.g. caps + a would run a certain application, etc). Now that I’m on Linux, I changed the behavior of caps from the system settings menu to become “make caps lock an additional hyper”. I then set a custom shortcut for caps + a to run the command: rofi -show run
This only works half the time. When I restart the computer, the option is still checked but it doesn’t work at all. I have to unswitch it and switch it again, and that freezes the system for a minute and sometimes doesn’t even work. Also, even when it’s working, this supposed hyper key actually functions like a super key (windows key), opening the menu when pressed.

I use fcitx5, and I’ve tried to mess with xkb (specifically by adding caps:hyper to /etc/default/keyboard, which didn’t work at all.) I’ve tried resorting to the ArchWiki X Keyboard instructions, but they’re waaaay over my head.

P.S. I’m not sure if this is relevant, but sometimes fcitx5 shows 2 icons on the system icons toolbar, and restarting fcitx5 from the drop menu freezes the computer for approximately 10 seconds.

Thank you in advance.


That shouldn’t go there at all.

I am on XFCE so I don’t know if this will work on KDE but you can try it.
If you have this path /etc/X11/xorg.conf.d/ , than in there you can create this file
00-keyboard.conf and add the following content

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbOptions" "caps:hyper"

If you already have the file than just add this Option "XkbOptions" "caps:hyper"


Holy god in heaven above, that actually worked. I have no idea why all the tutorials were telling me to edit the other file. Thank you, friend!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.