Can't use Nvidia proprietary drivers with RTX 3070 on a new manjaro install

When I try to boot the ISO with proprietary drivers it get stack and doesn’t boot.
If I try to boot the ISO with the free drivers it boot, and I’m able to go through the graphical installer (although there are many screen tearing because the neauvou driver is not very good), but then after I finish the installation and I install the proprietary driver and tried to reboot and doesn’t work.

Any suggestions?

What ISO are you using to install Manjaro? Give the exact name.

1 Like


I should add that when trying to boot the live ISO with proprietary drivers it’s getting stuck on something like:
“a start job is running for livemedia mhwd”

Did you wait enough time to boot? It may be longer to boot with the proprietary drivers.

1 Like

After something like 10 minutes I turned it off. How long do you think I should wait to make sure there’s a problem and it’s not just loading slowly?

10 minutes is obvioussly enough :slight_smile:

Maybe you can try a previous ISO with kernel 5.15, let me search a minute, I’ll edit the post.

Install with proprietary drivers and see if it works, then update the system :smiley: it is an old ISO.


Thanks, I’ll try it and edit this comment to report how it goes.

Edit: Thanks a lot!!! It worked, you have no idea how much you helped me.

1 Like

Out of curiosity post how the install went and any initial updates went after installing. I’m considering a 3050 and don’t want surprises. Thanks

1 Like

It went really smoothly, I didn’t have any issue at all.

1 Like

For those interested and looking at the 3050 I just found out the 2060 is a MUCH better card all a round.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.