Cant use modkey in dunst

hey all,

So, I am trying to set shortcuts in dunst, specifically for “Close Notification”. I’ve tried every possibilty: ctrl-space, mod1+space, mod4+space (mod4 [windowskey]) is my modkey for i3 but I’ve made sure space in not mapped there to anything. Still no dice. I do a “notify-send”, and hit the shortcut for “close” but the notification does not close. I’ve been banging my head against this for too long now. Does anyone have any idea?


Try adding this line in your i3 config:

bindsym $mod+k exec killall dunst

I’m using the i3-“spin” of manjaro, which has by default in .i3/config

bindsym $mod+Shift+d --release exec “killall dunst; exec notify-send ‘restart dunst’”

…which I run every time I change .config/dunst/dunstrc

Dunst doesn’t have shortcuts itself, you have to add this to your i3 config:

bindsym $mod+space exec dunstctl close

Edit: Apparently, they added shortcuts back in with 1.8. :person_shrugging:


    # Shortcuts are specified as [modifier+][modifier+]...key
    # Available modifiers are "ctrl", "mod1" (the alt-key), "mod2",
    # "mod3" and "mod4" (windows-key).
    # Xev might be helpful to find names for keys.
    # Close notification.
    close = ctrl+space

…is part of my .config/dunst/dunstrc …So I was assuming this was going to work, but for whatever reason I can’t get these to work.

Your solution of adding “dunstctl” commands and binding them to i3 key-shortcuts works great. Thanks a bunch :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.