Can't Use Double-TAB for completion of nordvpn commands, anymore

I recently did a new install of Manjaro/KDE. I did it with the hope that bash was still the default shell, but have found out that zsh is now the default. I have no experience with zsh, only bash. zsh is pretty and all, but TAB-TAB Completion doesn’t work correctly in zsh. Here’s what I am expecting:

~$ nordvpn set [TAB] [TAB] [list of available parameters for ‘set’ command]

Instead, all I get is a listing of directories instead of the available commands. Switching to bash in a different Konsole Profile does not bring back this functionality.

I have a laptop that doesn’t display this issue. The install is older, but I have a ton of desktops on it, and the terminal apps all work the same and are set to bash.

This is a Lenovo ThinkCentre All-In-One, with Win11 and Manjaro on a 1TB PCIe NVe card I just put in. The card/drive works fine, but not bash.

I would appreciate any insight into the problem.



To switch to bash do so using the konsole profiles.

That is create your own ‘firefishe’ profile and set ‘command’ to /usr/bin/bash.**

For bash completion that you are used to then just make sure to have bash-completion installed and something like the following in ~/.bashrc

[ -r /usr/share/bash-completion/bash_completion ] && . /usr/share/bash-completion/bash_completion

Note: I am sure completion works with zsh too, but I dont use it so …

What does that have to do with Manjaro presets? AUR packages are not officially supported. Either a program has shell completions included or they don’t.

You are free to choose whatever shell you wish.

Hi Yochanan, thank you for responding.

The reason I use that command as an example–and yes, it IS an AUR offering–is that it works with my laptop computer with Manjaro on it. So why doesn’t it work with a newer release? There is an answer for this, and I am aware I can use any shell I want, be it bash, zsh, ksh, what-have-you.

I plan on installing other desktop environments to use, and bash-completion is part-and-parcel to how I navigate the shell environment–usually bash–and has been that way for twenty odd years of gnu/linux.

Having to deal with this problem is a pain in the arse for me. I don’t usually get into scripts, as I’m an end-user and not a coder. I can decipher some things, and I’ve been researching a bit, but everything with bash-completion seems to be in order…I said seems to be. It may not, and probably isn’t, as TAB-TAB isn’t working, anymore.

TAB-TAB usually gets me the next set of commands that an application may offer. When in zsh, I can hit Escape, then Enter, and I get a detailed list from standard output, but not individual choices at the cursor, as would normally occur when using TAB-TAB for completion.


~$ nordvpn set thr [TAB TAB]
threatprotectionlite (which is what I was aiming for)

But all TAB-TAB does is give me directories to standard output. I need to get my completion functionality back.

Any technical ideas?

Hi cscs, thanks for responding.

Yeah, that line is in .bashrc. And I created a new Konsole Profile with /bin/bash as the shell. bash-completion still doesn’t work, it works like zsh. To me, this seems like a global setting in /etc/, or maybe /usr/share, or something.

I’m just fomenting ideas at the moment.

Any insight would be welcome.

And you have bash and bash-completion installed?

pacman -Qs bash

I’ll also leave the archwiki entry here

Yes, on both. I have looked at my laptop’s topography and will compare it to my desktop after work (I work nights), and I think there may be a difference.

The nordvpn AUR file may be different than the “nordvpn-bin” AUR application, so I may need to install the correct one. I noticed completion entries in /usr/share for both bash and zsh, so it may, indeed, be application-centric, so far as passing available set parameters to either shell environment.

Ah, to be learning again! :slight_smile:

Welcome to the Forum!

The “correct” one seems to be the nordvpn-bin build, since it pulls the official deb package that contains the file /usr/share/bash-completion/completions/nordvpn.

That’s probably the one providing the auto-complete functionality in bash.

Yes. That is the “solution” as far as it goes. I did find that file and I copied and pasted into the current configuration, and it works now.

This does not explain why the “nordvpn-bin” version, which draws from a .deb package to build the manjaro package (or arch package if you prefer), doesn’t work correctly when installed. It certainly builds faster than the docker-thing I’m using, although it all works properly. I guess my build environment is L33T (I’m sorry, I had to!) :rofl:

Okay then. I guess, for the moment, this is a good close to this topic. I’ll post another topic regarding the issues with the other AUR package–I’ll contact the maintainer, too, and see if they have an idea–and see if a solution to that can be had. As I said, the other package drawing from an already-compiled .deb goes a lot faster.

Talk to you later. I’ll mark your last post as Solution. Good Job, and Thanks! :grinning:

1 Like

So …
It was never all commands … but just the nordvpn ones? :expressionless:

Maybe we can keep the thread and solve intact if we edit the title. Done.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.