Can't use A2DP after latest update fixed after two reboots and replugging dongle, KDE. Can I changed intended role?

I was having trouble with my Bluetooth headset, it wasn’t applying A2DP just HSP. After I unplugged and replugged it worked as for now. But interesting thing, it says its intended use is for the phone profile which I think is the HSP mode. Is there a way to change this?

I installed pulseaudio-modules-bt trying to fix it before so don’t know if after 2 reboots it worked that out.

I also did this



pacmd list-cards:

index: 4
        name: <bluez_card.00_1D_DF_1C_7B_AB>
        driver: <module-bluez5-device.c>
        owner module: 35
                device.description = "Avantree NB16"
                device.string = "00:1D:DF:1C:7B:AB"
                device.api = "bluez"
                device.class = "sound"
                device.bus = "bluetooth"
                device.form_factor = "headset"
                bluez.path = "/org/bluez/hci0/dev_00_1D_DF_1C_7B_AB"
                bluez.class = "0x240404"
                bluez.alias = "Avantree NB16"
                device.icon_name = "audio-headset-bluetooth"
                device.intended_roles = "phone"
                headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, available: no)
                a2dp_sink_sbc: High Fidelity Playback (A2DP Sink: SBC) (priority 40, available: unknown)
                a2dp_sink_aac: High Fidelity Playback (A2DP Sink: AAC) (priority 40, available: yes)
                a2dp_sink_aptx: High Fidelity Playback (A2DP Sink: aptX) (priority 40, available: no)
                a2dp_sink_aptx_hd: High Fidelity Playback (A2DP Sink: aptX HD) (priority 40, available: no)
                a2dp_sink_ldac: High Fidelity Playback (A2DP Sink: LDAC) (priority 40, available: no)
                off: Off (priority 0, available: yes)
        active profile: <a2dp_sink_aac>
                bluez_sink.00_1D_DF_1C_7B_AB.a2dp_sink/#5: Avantree NB16
                bluez_sink.00_1D_DF_1C_7B_AB.a2dp_sink.monitor/#7: Monitor of Avantree NB16
                headset-output: Headset (priority 0, latency offset 0 usec, available: yes)

                headset-input: Headset (priority 0, latency offset 0 usec, available: no)

As I suspected, A2DP got borked again today :frowning:

I have to unplug the dongle and reboot without it, plug it after login and enable Bluetooth again.