Cant upgrade system

could not satisfy dependencies:
removing gtk3-classic breaks dependency 'gtk3-classic>=3.24.5' required by lib32-gtk3-classic
removing python2-dbus breaks dependency 'python2-dbus' required by xboxdrv

i get this everytime i run pacman -Syuu or update through the pamac

Hi @luzlmao, and welcome!

Please see the update announcement:

Hope it helps!

Those are both AUR packages. Check those are to be updated at the same time, or try

  • uninstall them
  • update
  • install them back
1 Like

also my os is 18.0.3

still wont work

error: key "6D42BDD116E0068F" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (6.0.1-2) breaks dependency 'pacman<5.2' required by pamac

That number has no meaning on a rolling distro if you’ve done your due dilligence and kept the system up to date.
Or do you mean to tell us you did just install from an old 18.0.3 iso?


Ah, either you did not update the system or you actually did just install from an old iso.

Download a current one and re-install.

There is no such thing.

1 Like

manjaro gaming dition
also my kernel is 4.9

its a custom build
link ttps://

That’s an unofficial spin which ISO hasn’t been updated since 2019!

You could try updating the hard way. If that doesn’t work, you will need to reinstall from a newer, official ISO.

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

i cant this is my only pc and etcher wont work