Can't update Zotero

hi everybody.
I’ve tried to update Zotero but end up with this error message:

node: error while loading shared libraries: cannot open shared object file: No such file or directory
==> ERROR: A failure occurred in prepare().

I’ve followed the instructions found in this thread:
However after rebuilding qt5-webkit nothing changed and I still get the same error… :slightly_frowning_face:
Any way out?
Many thanks :slightly_smiling_face:

is it from AUR or from normal repo?

it’s available from both

This should not happen with the repo version.

1 Like

My suggestions are:

  1. Use zotero-bin instead of zotero, or
  2. If your source of nodejs is also from the AUR, rebuild it.
1 Like

It’s from AUR.
Pamac doesn’t seem to find Zotero for me in the normal repo though, it can only find kbibtex :slightly_frowning_face:

1 thanks, I’ll try that
2 in my pc I have nodejs-Its-gallium and nodejs-nopt both from AUR installed. Should I also install nodejs from the official repo and delete these other 2 or what?
Thanks! :+1:

It seems you haven’t updated in awhile. First, make sure you’re fully up to date, then you need to rebuild zotero on the current version of icu which is 74.

Well, zotero does not depend on qt5-webkit. :wink:

Why? Node.js 16 has been EOL (End Of Life) for awhile now.

If you decide to install AUR packages, just remember you are the package maintainer and are responsible for maintaining them.

1 Like

This library is part of ICU. Icu is already at version 74, even in the stable branch. Either you install the package icu73-bin from AUR, or you look for containerized version, like flatpak, snap, appimage…the website of Zotero also offers a tar file, have you tried that? There are also several different zotero packages in the aur… so you have a lot of options.

p.s. i do not see icu at all as a dependency of the aur packages

p.p.s. i do hope you are familiar with AUR. Stuff like build essentials, being on unstable branch and fully updated should be obvious for you (insert better english word for selbstverständlich here :slight_smile: )

1 Like

well, I’ve updated every time Pamac told me to do so…
But sure I’ll follow the instructions at the link you kindly provided :grinning:

I guess this explains why it made no change then :smiley:

I don’t know. I guess, again, Pamac didn’t prompt me to do anything, and I didn’t :frowning_face:

I’d rather have installed Zotero from a Manjaro repo, but there was (is?) no alternative.

Thanks again for the infos :+1:

Installing icu73-bin seems to have done the trick.
Ich verstehe selbstverständlich, ich hab es gelernt zusammen mit “Mein Hut, der Hat Drei Ecke”, glaube ich. :smiley:

1 Like

I don’t know if Zotero was inherited from the Arch repositories, or not; but it doesn’t seem to exist now. Was/is it a Manjaro curated package (it’s not easy to check, currently)?

The Installation Instructions for the tarball previously mentioned are simple enough; and the package itself can be download directly from this link.

I hope this is useful. Cheers.

I don’t see Zotero in neither Arch nor Manjaro repositories. You should be able to install it from the AUR zotero-bin and run it then.
(I’m on unstable, however, so your mileage may vary.)