Can't update packages in AUR

I am trying to update three packages: teamviewer, visual-studio-code-bin, whitesur-kde-theme-git but I’m getting an error, what am I doing wrong? Newbie here.

yay -Syu                                                         ✔ 
[sudo] senha para denielton: 
:: Sincronizando a base de dados de pacotes...
 core está atualizado
 extra está atualizado
 community está atualizado
 multilib está atualizado
:: Iniciando atualização completa do sistema...
nada para fazer
:: Procurando atualizações nos bancos de dados...
:: Procurando atualizações no AUR...
 -> digimend-drivers-git-dkms: local (10.r3.g4762230-1) é mais recente que o AUR (10.r0.gec5c16d-1)
 -> Pacotes AUR ausentes:  linux513  linux513-headers
 -> Pacotes AUR marcados como desatualizados:  ncurses5-compat-libs
:: 3 Pacotes a atualizar.
3  aur/teamviewer              15.23.9-1     -> 15.24.5-1
2  aur/visual-studio-code-bin  1.62.3-1      -> 1.63.0-1
1  aur/whitesur-kde-theme-git  r61.7c95933-1 -> r66.c65b6cc-2
==> Pacotes a excluir: (ex: "1 2 3", "1-3", "^4" ou nome do repositório)
:: Verificando conflitos...
:: Verificando conflitos internos...
[Aur:3]  teamviewer-15.24.5-1  visual-studio-code-bin-1.63.0-1  whitesur-kde-theme-git-r66.c65b6cc-2

  3 teamviewer                               (Instalado) (Arquivos de Build Existem)
  2 visual-studio-code-bin                   (Instalado) (Arquivos de Build Existem)
  1 whitesur-kde-theme-git                   (Instalado) (Arquivos de Build Existem)
==> Limpar e construir quais pacotes?
==> [N]Nenhum [A]Todos [Ab]Abortar [I]Instalados [No]Não Instalados ou (1 2 3, 1-3, ^4)
:: PKGBUILD atualizado, Pulando (2/1): visual-studio-code-bin, teamviewer
:: (0/1) Downloaded PKGBUILD: whitesur-kde-theme-git
 -> erro ao buscar whitesur-kde-theme-git: error: Your local changes to the following files would be overwritten by merge:
Please commit your changes or stash them before you merge.
	 context: exit status 1

You need to delete the git repo of this pkgbuild: whitesur-kde-theme-git

I don’t know which AUR helper are you using and where the it saves the cached pkgbuilds

Another solution is to reset to master the whitesur-kde-theme-git pkgbuild but don’t know the command

nvm, I just tried right now to update this using pamac and it magically worked

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.