Can't uninstall Reaper

  Kernel: 6.5.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 Desktop: GNOME v: 44.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: EUCN19WW date: 05/12/2020
  ID-1: BAT0 charge: 42.4 Wh (100.0%) condition: 42.4/60.0 Wh (70.7%) volts: 17.0 min: 15.4
    model: Celxpert L19C4PC0 status: full
  Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
    rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 8 MiB
  Speed (MHz): avg: 1443 high: 1660 min/max: 1400/2900 boost: enabled cores: 1: 1398 2: 1640
    3: 1400 4: 1400 5: 1400 6: 1607 7: 1660 8: 1400 9: 1397 10: 1400 11: 1400 12: 1400 13: 1400
    14: 1397 15: 1397 16: 1397 bogomips: 92664
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Lenovo driver: nvidia v: 535.98
    arch: Turing bus-ID: 01:00.0
  Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 bus-ID: 05:00.0
    temp: 47.0 C
  Device-3: Chicony Integrated Camera driver: uvcvideo type: USB bus-ID: 1-3:2
  Display: x11 server: v: with: Xwayland v: 23.1.2 driver: X:
    loaded: amdgpu,nvidia dri: radeonsi gpu: amdgpu resolution: 1920x1080~120Hz
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 05:00.6
  Device-4: AKAI Professional M.I. MPK mini 3 driver: hid-generic,snd-usb-audio,usbhid type: USB
    bus-ID: 3-2:9
  API: ALSA v: k6.5.0-1-MANJARO status: kernel-api
  Server-1: sndiod v: N/A status: off
  Server-2: JACK v: 1.9.22 status: off
  Server-3: PipeWire v: 0.3.77 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel port: 2000 bus-ID: 03:00.0
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
  IF: wlp4s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB bus-ID: 3-3:3
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 362.37 GiB (76.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB temp: 43.9 C
  ID-1: / size: 459.72 GiB used: 362.37 GiB (78.8%) fs: ext4 dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p2
  System Temperatures: cpu: 59.6 C mobo: N/A gpu: amdgpu temp: 47.0 C
  Fan Speeds (RPM): N/A
  Processes: 388 Uptime: 17m Memory: total: 16 GiB note: est. available: 15 GiB
  used: 6.3 GiB (42.0%) Init: systemd Compilers: gcc: 13.2.1 clang: 15.0.7 Packages: 1746
  Client: gnome-shell v: 44.3 inxi: 3.3.28

I was trying out different DAWs and one of them is Reaper. Afterwards I decided to uninstall it, but it gives me this error - removing reaper breaks dependency 'reaper' required by reapack. How do I get rid of it?

Hi @wildcard,

Seeing as it’s a dependency of reapack, and if you don’t use repack I suggest you remove that as well:

pamac remove reapack reaper

Hope this helps!

I tried it and got this:

Error: Failed to prepare transaction:
could not satisfy dependencies:
- removing reaper breaks dependency 'reaper' required by sws

So I tried removing sws also and I guess that did it. Thanks!

So follow the deps…
You could look, like

pactree -r reaper

But, assuming this is it … then

sudo pacman -Rns reaper reapack sws

Yea, thanks! That did it. Removed everything.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.