Cant switch back to bash shell

I have recently re-installed my manjaro kde, and discovered they started to use zsh. I really dont like zsh, so I tried going back to the usua shell with chsh. I tried all, and managed to go back to the bash shell, however, commands dont work on it, only the prompt changes, and when I open a new terminal window its zsh again.

You have to log out and back in to properly take effect …

1 Like

tried that, also tried total reboot and doesnt work

I found out that if you use konsole, you have to change the shell in the settings. For some reason it doesn’t use the user’s default.


As mentioned above, check what profile is Konsole using and switch to point to /bin/bash


chsh -s /bin/bash can set default sh to bash. after done this ,you should logout
or `/bin/bash’ to temp change to bash

Thank you so much, you saved me

Thanks, this worked perfect

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.