Can't set VPN to start on connection: nm-connection-editor crashes

I have been using Manjaro (GNOME) and an OVPN file to connect to my VPN. Although the default GNOME GUI network manager does not provide an option to “Automatically connect to VPN,” this is available under “General” tab if you type nm-connection-editor into a terminal.

However, recently when I try to set an automatic VPN connection via this method, nm-connection-editor crashes as soon as I select the radio button next to “Automatically connect to VPN.” The error is: Segmentation fault (core dumped).

The only bugs I’ve seen reported on this say to install gnome-keyring, but that is already installed.

Can anyone reproduce this or provide a solution or workaround?

This is a serious issue. Could not find any workaround for it yet :frowning:
Steps to reproduce:

  1. Install manjaro gnome
  2. Connect with a wired connection
  3. setup a vpn
  4. open nm-connection-editor
  5. edit wired connection
  6. try to enable the auto connect to vpn

The the application crashes with the following error:

(nm-connection-editor:8953): Gtk-WARNING **: 07:16:37.552: GtkGrid does not have a child property called expand
(nm-connection-editor:8953): Gtk-WARNING **: 07:16:37.552: GtkGrid does not have a child property called fill
zsh: segmentation fault (core dumped)  nm-connection-editor

Same is true if a wireless connection is used.

Can confirm, I am on normal Arch Linux with Network Manager and have been having this issue for many months. Reproduced with the same steps with wireless

Here is a temporary fix using the terminal,

first find the uuid of your vpn conneciton

Example of my own config

$ nmcli co

NAME                          UUID                                  TYPE  DEVICE
au-syd_openvpn                3e8e26ba-f7c0-4311-a657-cd9d4144d097  vpn   wlan0
JamJam6                       0fe0d044-2fae-4a5a-816c-b2014715c9dd  wifi  wlan0

Then set the secondaries option of your device to the UUID to autostart the vpn on connect.

In my case (JamJam6 is an example)

nmcli co modify JamJam6 connection.secondaries 3e8e26ba-f7c0-4311-a657-cd9d4144d097

Now restart your network connection, and it will autostart the vpn.

nmcli co down JamJam6
nmcli co up JamJam6

To reverse changes,

nmcli co modify JamJam6 connection.secondaries ""

BE WARNED, your nm-connection-editor will crash immediately when trying to edit the device with the secondaries option enabled. If you want to edit without cli, turn off the connection.secondaries and it will work again.

As I said, this is a temp fix, hope the gui gets fixed soon.

To see all your options on the cli

nmcli co show JamJam6

See more at man nmcli-settings and man nmcli-examples


Brilliant, that fixes it. For those that have network names that contain blanks; put the name in quotation marks, like

nmcli co modify "Jam Jam 6" connection.secondaries 
1 Like

This has been resolved for me as of the latest Network Manager update, as I have tested on my Arch. Try test it now. If it works we should mark this as solved