Cant set up keyboard in english for using portuguese accents

My thinkpad lenovo have it’s keyboard in english, so there are few things I’m only able to use if I set up Manjaro’s keyboard to English. But whenever I try to use graphic accents from my native language (Portuguese) there is no way. It just don’t work. Can someone help me?

Add Portuguese layout and the variant that works for you, and switch between the two whenever you need to have accents.
Settings > Keyboard > Layout and you click on the + Add button

After that you select one of the two Portuguese with one of the variants that is proper for your keyboard


After you add it you can define the shortcut to change the Layout …

1 Like

Oh thats a option, but I remember being able (of course, that was on Windows) to use English keyboard and having accents.

For exemple, when we put ’ + e, we’d get an e with accent. I need to have a Portuguese keyboard but with the layout displayed in my laptop keyboard. Example: whenever I put my keyboard in Portuguese, I don’t have access to '**\** or **|**' because the key where they’re placed on Portuguese keyboards, doesn’t exists on my english one.

You can use the English (US) with the Alt Int mode.
All works except for ç
You can fix the ç with this script: wget -q -O fix-cedilla
chmod 755 fix-cedilla

Source GitHub - marcopaganini/gnome-cedilla-fix: A fix to make the Gnome "US-International" layouts generate a cedilla c (ç) when the user types '+c.