Can't set a higher resolution than 1024x768


I am unable to set my resolution higher than 1024x768.
I have a 17 inch Monitor which supports resolution upto 1280x1024 and my CPU is a i5 2nd gen ( No GPU ).

I know that resolution can be manually created via xrandr but that’s not an ideal solution. I have to do the script every restart which I find annoying.

There’s no other way then. You have to add a undetected resolution permanently. See xrandr - ArchWiki

Are you sure? Is this a driver issue or I just can’t change my resolution higher than that with intel intregrated graphics?

Hi @DidntPot,

If you know how to do it with Xrandr you can setup the command to automatically execute on boot.

How? Any example or links to any sources?

OK, I have absolutely NO idea if this is the correct way, but this is, at least one way:

  1. Create a file in ~/.config/plasma-workspace/env/ to be executed on every boot. Let’s call it
touch ~/.config/plasma-workspace/env/
  1. Open the file in your preferred editor. Lets use nano.
nano ~/.config/plasma-workspace/env/
  1. In the file, add a shebang (the line starting with #!) and the command followed by the line with the actual command:
#!/bin/env bash
<actual xrandr command>

Where <actual xrandr command> is the actual command you’d use with xrandr

  1. Save the file, Ctrl+OY, and exit, Ctrl+XY.

  2. Make the file executable:

chmod +x ~/.config/plasma-workspace/env/

And reboot.


This will only work for the currently logged in user after login. It isn’t global. For global, you’d need to create a systemd unit, which while I don’t think is too hard, I’ve just never done it. See here for more:

1 Like

You’re using KDE and you should be able to change the screen resolution from system settings → display and monitor → display configuration.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.