Can't search for files in application launchers except in Kickoff

Recently I noticed I can’t search for anything than apps in application launchers, even though

  • Baloo is enabled and the files I’m searching for are indexed, and
  • Locations plugin in Plasma search settings is enabled.

At first I thought that maybe it’s an issue with Baloo index, so I tried purging it and reindexing everything from scratch, but that didn’t help.

I’m using GitHub - Zren/plasma-applet-tiledmenu as an application launcher, but it seems that none of others shipped by default with Plasma, or other installed from the store, work either, except Kickoff. There it works just fine.

Operating System: Manjaro Linux
KDE Plasma Version: 5.25.2
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Kernel Version: 5.18.10-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 2600 Six-Core Processor
Memory: 15,5 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2

Is the search for files working via KRunner directly? Modify some of the search plugin options, apply and then test again.

In Krunner everything is fine.
I already tried either disabling them or unchecking some of them, and nothing seem to work.

This very much looks like it is a bug of plasma 5.25 from upstream. Desktop search was changed with this release (Krunner; Overview). You can report it upstream if you have an account at KDE bug tracker.

I thought so but wasn’t really sure.
Thank you, I’ll report it.

Tested it myself on different installs. While working on a 5.24.2 but not working on any 5.25.2 install with any launcher other than standard kickoff.
It seems to be an issue with the launcher settings: Search: Expand search to files, bookmarks, and emails (aka Desktop search).

Another way is to wait for a fix. 5.25 is new and many bugs do get fixed over time. I haven’t found a bug report upstream about it yet.

Reported, 456562 – Searching for files in application launchers fails.
I wasn’t really sure about the category though.

1 Like

Thanks a lot for your bug report!

It’s actually an issue with the frameworks packages (kf5) and not plasma-desktop. The problem also exists on plasma 5.24.5 which is currently in stable branch. I suppose the error came with FW 5.95.

Frameworks 5.96 was already released and will be in unstable in a few days I guess. Let’s hope 5.96 fixes it automatically. As long as Krunner works I am happy :).

1 Like