Can't scan from HP 5200 OfficeJet

I can’t scan from my HP 5200 Office Jet, except for the web interface by going to the URL for the printer/scanner. The printer/scanner is connected via USB. Scanimage -L just hangs with no output. Sane-find-scanner shows the scanner on the USB and so does lsusb. Any attempts to run scanner front ends like Simple Scan also hang when looking for scanners. I also tried the hp app. Running hp-scan hangs, too, just like scanimage -L. I can access the same scanner from another machine running Manjaro using network access and it works fine.

Yesterday, I deleted all scanner apps from this machine and reinstalled them following steps in the Arch wiki article on sane. The scanner was working. When I tried today after shutting down and rebooting, it didn’t work again.

Does anyone know how to troubleshoot scanimage? When it hangs, it’s impossible to kill the process. I have to close the terminal window.

I’d certainly appreciate any help on troubleshooting. Thans.