Can't save input settings in RetroArch

I have been trying to edit the input settings for my controller inside of RetroArch flatpak version (I do not have this issue on the official repository version, but I had to remove that one because of various reasons), but it keeps giving an error: Error saving autoconf file. Tbh that’s all the information I have, I don’t if my inxi would be helpful for this one, but here it is anyways:

  Kernel: 5.4.60-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=fabca885-904e-499f-b9ca-17bdfb51a1a2 rw quiet apparmor=1 
  security=apparmor resume=UUID=7429e984-f57f-46d7-bebf-8e0882fa0a7a 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 20DM000VUS v: ThinkPad S3 Yoga 14 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20DM000VUS v: SDK0E50512 STD serial: <filter> 
  UEFI: LENOVO v: JGET34WW (1.20 ) date: 12/04/2018 
  ID-1: BAT0 charge: N/A condition: N/A volts: N/A model: N/A type: Li-ion 
  serial: <filter> status: Charging 
  Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 45 (69) stepping: 1 microcode: 26 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 19161 
  Speed: 1342 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1137 2: 1143 
  3: 1128 4: 1131 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0a16 
  Device-2: NVIDIA GM108M [GeForce 840M] vendor: Lenovo driver: nvidia 
  v: 450.66 alternate: nouveau,nvidia_drm bus ID: 04:00.0 chip ID: 10de:1341 
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo bus ID: 1-7:5 
  chip ID: 04f2:b46a serial: <filter> 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 20.1.6 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c 
  Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
  Sound Server: ALSA v: k5.4.60-2-MANJARO 
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: efa0 
  bus ID: 02:00.0 chip ID: 8086:08b2 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 480.68 GiB used: 25.49 GiB (5.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-9WS142 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
  ID-2: /dev/sdb vendor: SanDisk model: SSD U110 16GB size: 14.91 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 001 scheme: MBR 
  ID-1: / raw size: 24.41 GiB size: 23.91 GiB (97.92%) used: 13.92 GiB (58.2%) 
  fs: ext4 dev: /dev/sda8 
  ID-2: /home raw size: 127.64 GiB size: 125.13 GiB (98.04%) 
  used: 11.58 GiB (9.3%) fs: ext4 dev: /dev/sda9 
  Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 3.91 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda7 
  System Temperatures: cpu: 71.0 C mobo: 45.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 195 Uptime: 1h 07m Memory: 7.69 GiB used: 1.82 GiB (23.7%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1268 
  pacman: 1261 lib: 331 flatpak: 7 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.05
1 Like

Yup, that’s the intended consequence of flatpacks or snaps as they run inside a silo and you can only change the settings that the application packager wants you to change and one of the main reasons I switched to Manjaro. :sob:

So you have two options:

  1. Go back to the AUR version
  2. File a bug with the flatpack packager.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.