Can't run steam games

I have upgraded my gpu recently from a RX 550 to a GTX 960. With that said, I can only play OpenGL Games, Vulkan and lib32 rendered games are not playable anymore.

I am using Manjaro Pahvo 21.1.0 with linux kernel 5.12.19-1:

[chandler@chandler-PC ~]$ uname -a
Linux chandler-PC 5.12.19-1-MANJARO #1 SMP PREEMPT Tue Jul 20 20:57:37 UTC 2021 x86_64 GNU/Linux

These are my GPU specs from inxi:

Device-1: NVIDIA GM206 [GeForce GTX 960] driver: nouveau v: kernel
alternate: nvidia_drm,nvidia bus-ID: 0a:00.0 chip-ID: 10de:1401
class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 676x380mm (26.6x15.0")
s-diag: 775mm (30.5")
Monitor-1: HDMI-1 res: 2560x1440 hz: 60 dpi: 107
size: 608x345mm (23.9x13.6") diag: 699mm (27.5")
OpenGL: renderer: NV126 v: 4.3 Mesa 21.1.6 direct render: Yes

These are my nvidia packages installed from the Official Repository:

When I try to launch nvidia-smi, it returns:

[chandler@chandler-PC ~]$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Could someone help me, please?

The nvidia driver is there, but you forgot to blacklist nouveau and therefore nouveau has been loaded first. This is normally done by using mhwd.


Thank you so much, I have searched for more info and found this topic. bogdancovaciu gave a hint by telling to do:

sudo mhwd -r pci video-linux
sudo mhwd -i pci video-nvidia

After that, I rebooted the machine and now it is working!!

Just a quick reminder:

Installing the proprietary nvidia drivers (I tried using 390 and 470), the fonts WILL be scaled up even with a correct font settings and setting the global scale to 100% in the compositor.

To overcome this issue, there is a thread closed in this forum recommending to force the driver to set a fixed DPI by editing (as sudo) the file /etc/X11/mhwd.d/nvidia.conf in the section "Monitor" by adding the line:

Option "DPI" "96 x 96"

and rebooting.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.