Can't run script on system startup (Manjaro KDE)

I installed and configured Fusuma to add touchpad gestures to my Manjaro KDE, and now I would like to autostart Fusuma with my system instead of having to run fusuma -d manually every time.

I tried creating a .sh file with the following text and adding it to autostart settings, but nothing happens after system reboot.

#!/usr/bin/env bash
fusuma -d

Furthermore, I also tried saving the file in ~/.config/plasma-desktop/env following this post, but it’s still not working for me.
What am I doing wrong?

PS: Note that the file works properly if I manually run it

I would propose a different approach.

Add the script to /etc/X11/xinit/xinitrc.d/. Make sure that it has an appropriate number (which will determine its order in the list) in its filename ─ e.g. ─ and that it is root-owned and has execute permission.

Also, make sure that your script contains the full path to where the executable fusuma is located, e.g. … :arrow_down:

/usr/bin/fusuma -d

Thank you!
The problem was the full path of fusuma executable, now it works also with the previous approach :smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.