Can't RPI4 connect to wifi, already tried nmcli

Hi, everyone. As the title says I’m currently trying to connect my raspberry pi 4 to Wifi. I’m running Manjaro ARM Linux aarch64.

OS: Manjaro ARM Linux aarch64
Host: Raspberry Pi 4 Model B Rev 1.2
Kernel: 5.15.89-1-MANJARO-ARM-RPI
DE: Plasma 5.26.5

About the problem:

  1. When i click on wifi, and choose the SSID, once filled the password requirement box, it keeps asking me the password again, and again…
  2. Checked the password, and it’s working on my other devices.
  3. The NetworkManager, tries to access the network a few times. Then it says <SSID_NAME> is deactivated, the same for WLAN0.

About the solutions I’ve tried:

  1. Use nmcli.
  2. checked the connection values in /etc/NetworkManager/system-connections/

No one allows me to wifi connect.

So, in conclusion, could anybody give me a hand with this project ? I’ll really appreciate it.

Without the log, there’s not much to check.
Sometimes, the encryption of your WiFi is too old or too new for the chip.

1 Like