Can't remove panels

Hello, I’m a new user to KDE and I’m testing panels and widgets.
I had a very stupid problem and I can’t solve it, tried searching in the old forum, KDE in general and in here.
I need to remove some panels, I can do that, widgets on them included but when I log in again the panels and widgets are back.
I tried all the methods available. Is there anything to do with Activities? I tried deleting them, create new ones before and after deleting panels. I don’t want any virtual desktop btw.
I running the last version available and no updates needed.
I can’t upload an image, I think is because I’m new: Screenshot-from-2020-08-25-21-22-01 — ImgBB
Thanks in advance.

I think maybe you have ‘saved sessions’ activated.
I think maybe there is a way to set or clear it … I personally find it obnoxious so its just disabled.
(why do we want to save a desktop with some windows open so that login is slower and they pop up again?)

System Settings > Startup and Shutdown > Desktop Session > "On Login" Section > Start with Empty Session

Thanks for the instant reply. I have that option set to “Start with an empty session”.
I find it annoying too).

Boo.
Theres probably some acrobatic way to deal with this
For example I think most is configured in ~/.config/plasma-org.kde.plasma.desktop-appletsrc
But short of gutting all plasma settings … maybe an easier thing to do would be to select a different look-and-feel or “Global” theme. (this will set desktop items to that theme default … but then you can reset from there)

…also … you might be in luck. I found a little script I made for someone with a somewhat similar issue I cant remember… here it is:

panelpluckr.sh
#!/usr/bin/env bash
#               panelpluckr.sh               #
## To automate the killing of Plasma panels ##
#####                cscs                #####
sed -i.bak -e '/./{H;$!d;}' -e 'x;/ActionPlugins/b' -e '/[9]/b' -e '/ScreenMapping/b' -e d /home/$USER/.config/plasma-org.kde.plasma.desktop-appletsrc ;
qdbus org.kde.KWin /KWin reconfigure ; 
kquitapp5 plasmashell > /dev/null 2>&1 && kstart5 plasmashell > /dev/null 2>&1 ; 
echo -e "\nPanels now removed. Previous configuration file saved as\n\"plasma-org.kde.plasma.desktop-appletsrc.bak\"\n" ;
exit

I havent looked at that in at least some months … I dont know if it applies … but it looks fine … you can give it a go if you want.

PS - if you dont know how … heres a quick tutorial.

  • Save the content as a file. We will use panelpluckr.sh
  • mark executable with chmod +x panelpluckr.sh
  • run with ./panelpluckr.sh
1 Like

Your detailed explanation and script save me from pulling and old backup.
I had already tried to change the global them and plasma styles with no luck.
I can’t believe I’m not able to perform that simple task. Hopefully I don’t customise a my desktop at all and with a few clicks I have my simple taskbar running great.
Thanks again!

Yes… I am not sure how the ‘cache’ gets written/saved/stuck … as far as I know it should all end up in that file … yet you arent the first to say that somehow changes arent saved.
So augmenting the file directly seems the way to force it … the script just tries to remove what it thinks are ‘panels’ in that file after copying the original for ‘just in case’.
(and then restarts plasma and prints a message)
I am sorry but I didnt quite understand - are you saying the script was what worked then?
In whatever case, if its working now than great :slight_smile:

English is not my native language, maybe I couldn’t explain myself.
The script did the trick. I searched inside the config file and recognised the elements but I didn’t want to mess with it. I decided to use the script knowing it will erase everything (you warned and I checked) including the useful one. I had a very simple taskbar with only a menu app, a clock and a system tray so it took me like a minute to create it again.
Thanks for all the info, now I know where the config file is and I can make a backup before making any change.

No worries.
Your english is very good. I just wanted to clarify.
(especially in the case I might offer it to someone else)
Cheers :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.