Cant remove git clone apps

i cant remove evillimiter. i got form github , and typed … git clone GitHub - bitbrute/evillimiter: Tool that monitors, analyzes and limits the bandwidth of devices on the local network without administrative access. , and i was tried to remove this or uninstall but i cant fix , and i tried with ALT + . for hidden files then i found evillimiter and removed , but i can still access , i dont know how to remove evillimiter , or any git clone apps . so anyone help me.

Just reverse the process you used when you added it - usually the README or INSTALL file describes how to accomplish.

If you ran sudo make install then run sudo make uninstall

If all you did was, and only,

git clone

then you can simply delete the folder it created, as the git clone command merely copies the source locally.

its git clone not install or uninstall ,

I took a look at the github page.

To install you ran

sudo python install

This is a mistake with Manjaro (and any Arch based system) as it installs files to system location without using pacman - and thus opens for problems at a later point in time.

So the logic is you reverse the install command - but I am not sure it will work when installed as you did.

I also took a look at AUR and the package installation is available as a build script.

The files installed are spread over a number of locations - which is why you need pacman to keep the account.

You could open the file in a text editor - then look at the setup section to get an idea where the files were copied to - then manually remove them.

Manually editing any system location with a file manager or the terminal is dangerous business especially when as inexperienced as you are.

So I will recommend another approach. Build the package from AUR - attempt installation - then you know where the files are - because pacman will generate several conflict messages.

sudo pacman -Syu base-devel
git clone
cd evillimiter
makepkg -si

Then clean up the mess - you still need to be careful - not to accidentally remove a folder which should not have been removed.

The last suggestion is to tell pacman to overwrite the existing files.
2021-11-23T06:47:00Z the version in aur is 1.5.0-1 so using below command to install the package will overwrite the files - moving control to pacman

sudo pacman -U evillimiter-1.5.0-1.pkg.tar.zst --overwrite '*'

When pacman is in control it is easy to remove

sudo pacman -Rns evillimiter

thanks for this details , but i got another error
*Warning: python-netaddr: /usr/bin/netaddr already exists in filesystem
It has been backed up to /usr/bin/netaddr.old
Warning: python-tqdm: /usr/bin/tqdm already exists in filesystem
It has been backed up to /usr/bin/tqdm.old
Warning: evillimiter: /usr/bin/evillimiter already exists in filesystem
It has been backed up to /usr/bin/evillimiter.old

  • what should i do ?

and this error too - Mac address to reach destination not found. Using broadcast.
WARNING: Mac address to reach destination not found. Using broadcast.

I can’t help with an applicaiton where I don’t know what it’s doing - it seems likely the application has changed your network configuration and manually removing the app (if that is what you are doing) is causing network issues.

To solve your issue you must install the app - use the method from above - using the --overwrite ‘*’ argument.

Then use the application to undo what-ever changes you have made to your system - only then you can rermove it without cause other issues - you could hope.

i found this solution, to go Add/Remove software , then - installed - Foreign , i found evillimiter , and uninstalled , it will work for git clone

Never use sudo with pip. If you keep blindly installing things manually, you’re going to keep running into problems like this.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.