Can't read superblock on HDD partition

Hi there, this is my first time over on this forum so please bear with me if I end up accidentally not complying to any rule.

With that said, last night, after rebooting my laptop, I couldn’t get it to boot normally again (it kept putting me in some recovery mode [a feature of systemd? anyway…]). Apparently I wasn’t able to boot normally because, when trying to mount /dev/sda13, an error was occurrying, which said something along the lines of:

mount: /patch: can't read superblock on /dev/sda13.
       dmesg(1) may have more information after failed mount system call.

After removing /patch from my /etc/fstab, I was able to boot normally, but couldn’t get back to mounting the /dev/sda13 partition. I, then, ran dmesg to get more info, but couldn’t really understand what it was trying to tell me. Here’s what I got from it: dmesg output on superblock issue -

Then, I tried following a few guides, which the forum won’t let me link here for others to see, on how to supposedly solve this issue, but none of them worked.

Lastly I used gsmartcontrol (a GUI around smartctl) to try and see if my issue was being caused by a hardware failure, but, again, I couldn’t understand all the technical mumbo jumbo that this tool generated. I ran this command:

'smartctl' --health --info --get=all --capabilities --attributes --format=brief --log=xerror,50,error --log=xselftest,50,selftest --log=selective --log=directory --log=scttemp --log=scterc --log=devstat --log=sataphy '/dev/sda'

And got this output: smartctl output on superblock issue -

Ultimately I want to know how to fix this issue so that I can, again, be able to mount /dev/sda13 (I mean, assuming there hasn’t been an unrecoverable hardware failure)

I don’t know if this is of importance, but the other partitions on this same HDD seem to be working fine and my kernel is 5.10.133-1-MANJARO (I guess I’ll be updating it while this post waits for replies).

Important are these lines to detect errors:

  5 Reallocated_Sector_Ct   PO--CK   252   252   010    -    0
  7 Seek_Error_Rate         -OSR-K   252   252   051    -    0
 13 Read_Soft_Error_Rate    -O-RCK   100   100   000    -    0

So the Raw values are ZERO, so no physical problem here.

But the errors below look like a loose contact or defect cable. Consider to check this.

So I assume it is a corrupt filesystem because of a loose contact. Here is a short explanation if it is EXT4 filesystem:

1 Like