Can't re-install drivers on Manjaro

Hi there. So yesterday I bought Skyrim and downloaded it through Steam, but it was not launching for some reason. Confused I searched for it online and found out that Proton-6.16-GE-1 could solve the issue, however it didn’t. What was even more strange was the fact that I couldn’t run some other games that were running perfectly before, so I though about reinstalling my drivers, and to my surprise, the process failed. I assumed it would be because I updated my kernel yesterday so I switched to the 5.12.19-1 LTS but I am still facing the same issue. Here is the output I get when I try to reinstall my drivers (I am using an nVidia 2060 along with an Intel Graphics Card, so my installed driver is the video-hybrid-intel-nvidia-prime):

> Removing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-utils breaks dependency 'nvidia-utils' required by cuda
Error: pacman failed!
Error: script failed!

Done ...

I get this exact same output when I try to remove the driver and I couldn’t find any similar post online about this issue. Thanks in advance.

It may not be the drivers, there’s an issue with steam and the latest update. Installing steam bets fixes it. Not certain it’s your issue but certainly worth checking

I had already an issue with Steam before that was solved by switching to the beta program. I didn’t have any issues whatsoever with other games before trying to install Skyrim.

Problem solved! The problem was that I installed optimus and it was interfering with the drivers, so it’s all good now, the game is running again. Thanks for your patience!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.