Can't print from Gnome Web (Epiphany)


today i tried to print a webpage to pdf. The print dialog opens, i select folder and filename and click to “Print”. No error messages, but no print output.

Doing the same thing with firefox works well.

I can print pdfs from other gnome apps, like gedit.
I tried to reproduce the issue starting epiphany from terminal, but no error message regarding print was displayed.
Just a missing libnuspell dependency (which i resolved installing nuspell from official repos) and several time-out errors when Epiphany was trying to populate passwords from Firefox Sync.

Does this issue happens to someone else?

I had this happen to me, except that I do see a dialog to print… when I tell it to print-to-file, and give it all the settings I want (PDF, filepath, etc), it complains that the path doesn’t exist.

But… the path that it displays has garbage characters to the front and end of the path.

This said, I am running the XFCE desktop, not Gnome. I only installed Epiphany because I needed to reproduce a problem seen with someone’s Safari browser, and that’s the closest one to it that I could find for Linux (and I really wanted to see the PDF output from the browser as part of my test efforts).