Can't open system settings since last update

Can’t open system settings on budgie. I remember the settings crashed after clicking the multitasking option, and I haven’t been able to open them since!

(gnome-control-center:42203): GLib-GIO-ERROR **: 09:35:24.759: Settings schema '' is not installed
[1]    42203 trace trap (core dumped)  gnome-control-center

Also I am wondering if I should continue with budgie or not. I love the desktop and it stays out of my way, but looks like the developeres are moving away from gnome. So will the future gnome / manjaro updates keep breaking little things? Developing a DE is going to take them a long time.

1 Like

There is a patch from Solus dev to handle this issue. Can’t say if it will work for Manjaro Budgie.

Okay I found a temporary workaround. I remembered that it crashed when I viewed “multitasking” panel. So I used gsettings to check the keys of org.gnome.ControlCenter

gsettings list-keys org.gnome.ControlCenter 

then check

gsettings get org.gnome.ControlCenter last-panel 

this is the problematic panel that was crashing the control center every time. So I did

gsettings reset org.gnome.ControlCenter last-panel

and voila, I can open settings again. Not touching that panel till this gets fixed!


Oh wow, thank you for adding your workaround. I just had the same error happen to me and I think yours was the one that reminded me that i last clicked on multitasking.
Really annoying bug.

1 Like

Thanks for the workaround, worked perfectly. I did the same mistake that I clicked on the multitask panel but unlike you I couldn’t remember that I pressed it. Only found this thread coincidentally when searing for Settings schema '' is not installed which appears in the journalctl when starting the settings.

1 Like