Can't open psd files GIMP

Hello. When I try to open a psd file in GIMP, the program freezes and closes. My system is a KDE plasma 5.24.3

Start the program from a terminal.
There will probably be something written to it re the cause.

No, that doesn’t work either.

Since it works just fine for me - with sample .psd files downloaded from the net, because I do not have any of my own
I can only suggest that you try again with:

gimp --verbose

in a terminal

and see whether the output might reveal something
It should start up - and then only crash/close/whatever once you open your image.

I tried some of these:

Sample PSD Files | Customer's Canvas

and some from here:

worked all just fine …

I have a suggestion as to why this doesn’t work: I have an Nvidia graphics card and only open source drivers are installed. Can GIMP not work because of this?

That is (just) a guess.
Based perhaps on the various problems with Nvidia cards reported here.
(this is a forum where problems, rather than successes, are reported …)

But, really:
if it works otherwise for anything else, I see no reason that your issue is connected to that fact.
… yes, it could always be - nothing is impossible :wink:
but it is highly unlikely

Let the data speak - if there is any to have.
Let’s try to gather and work on facts … not guesses :wink:

How are any of these files (my links) working for you?

GIMP --verbose only says this:
(file-psd:1995): LibGimpBase-WARNING **: 18:06:03.980: file-psd: gimp_wire_read(): error

(script-fu:1929): LibGimpBase-WARNING **: 18:06:03.982: script-fu: gimp_wire_read(): error
zsh: killed gimp --verbose

there is a directory called:
perhaps it holds something useful?

For lack of knowledge
I’d try
to back up (in case it may contain anything valuable)
and then remove
and everything in it

… to start anew …

Are you sure that your system is fully updated?
If not - that would be the first thing to ensure.

That’s the whole point - the CrashLog folder is empty. GIMP just won’t open the file. I can’t understand this

And yes, system is fully updated

Where those errors when you tried to open up the .psd files linked to by @Nachlese?

Details are important.

:ok_hand: this!


are any non-standard plugins installed?
I really do not know much about gimp in particular - but this could be one reason
It could also be rectified (probably) by removing ~/.config/GIMP
… thereby losing those …

Based on an old Reddit post, it might be related to the GTK theme you are using.

Try a different theme, and see if it helps:

System Settings → Appearance → Application Style → Configure GNOME/GTK Application Style

But first, try @Nachlese’s suggestion of a new, fresh GIMP profile config folder.

As this could be script/plugin related.