Can't open grub menu, but really need to change kernel


After the new update my system automatically changed back to the my old zen kernel that simply doesn’t work with Manjaro right now (disabled screenbrightness and some window animations are gone as well, it’s not like totally broken, but it’s annoying). I don’t have grub timeout set on hidden, I have it on 5 seconds, in the default/grub file. And yet, it doesn’t show up. I also tried pressing esc, shift and F8 during reboot. Nothing happens. I’m so frustrated. How do I finally change the kernel again? It was a mistake to install a alternative kernel, now I only have problems with it :S

Thanks for any help!

Boot up from the Manjaro live USB and open a terminal window. Then issue the following commands… :point_down:

sudo su -
manjaro-chroot -a
grub-install --recheck
mhwd-kernel -i linux61
mhwd-kernel -r linux-zen  # (if that is what it's called)

If you still don’t see the GRUB menu at the next boot, then there must be something wrong with how you installed it in the first place, but without further information, we cannot possibly know. :man_shrugging:

1 Like


The kernel is called 6.4.14-zen1-1-zen (linux64). I don’t have the live USB with me right now as I’m not at home, so I will try this later and then update on it.

Edit: Hey, so small update: It worked out and now everything is back to normal! Thank you so much for the reply!

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.