Can't open desktop

The problem started when I had a little issue with my audio. I found out that there are 2 audio services pulse audio and pipewire. I found out that pulse audio is the main service, so I thought that deleting pipewire might solve my problem. So I used this command sudo pacman -Rcns pipewire , then I did a reboot. After the reboot there is a new type of login screen. I entered my password and pressed enter key but nothing happened. I will attach a picture of the login screen, in that I just covered my name.

Please tell me how to fix it

well pipewire has a lot of dependencies so you messed up your system completely …
can you enter into tty?: ctrl+alt+f2 - or f1-f6 keys instead - press it on the login screen

Yes, something like a terminal opened

so enter your username/ password and try to install pipewire:
sudo pacman -S pipewire
and hopefully it will install with it all dependencies, reboot
systemctl reboot

This is not enough.

He removed all of KDE because it depends on pipewire.

There should be a group/virtual package to install the full DE again.

Edit: Maybe pamac install plasma kio-extras

I don’t know why but it says login incorrect

yes you need to install back what you removed with pipewire, check with:
cat /var/log/pacman.log | grep removed
and install all packages back that were removed from today, then reboot

But how do I login. It keeps saying login incorrect

you enter again into tty, you run the cat command, and install back the packages

I am saying about this that I can’t login

were you able to login before when you were installing back pipewire?
check caps lock and num lock

I didn’t install pipewire yet because I cannot login

so if you can login thats a problem …
do you have a manjaro usb?
if yes boot it, and we will repair your installation from there

I don’t have it now but I will get back to you when I have it

so when you have it, boot it, connect to internet, open terminal, and chroot with this:
sudo manjaro-chroot -a
then post output from:
cat /var/log/pacman.log | grep removed
post only entries from today

I fixed it. First in the place of username instead of entering my username and password I entered root as my username and my password then it gave me access. I installed pipewire, plasma, and kio-extras. Then I rebooted the login screen is still the same but I can enter the password and go to the desktop. I have done the pacman -Syu everything was updated. This is my log file

[2022-08-21T14:34:45+0530] [ALPM] removed sddm-kcm (5.24.6-1)
[2022-08-21T14:34:47+0530] [ALPM] removed plasma-desktop (5.24.6-1)
[2022-08-21T14:34:47+0530] [ALPM] removed polkit-kde-agent (5.24.6-1)
[2022-08-21T14:34:48+0530] [ALPM] removed libibus (1.5.26-2)
[2022-08-21T14:34:48+0530] [ALPM] removed manjaro-kde-settings (20220130-1)
[2022-08-21T14:34:48+0530] [ALPM] removed plasma5-themes-breath (21.3.0-4)
[2022-08-21T14:34:48+0530] [ALPM] removed plasma5-themes-breath-migration (21.3.0-4)
[2022-08-21T14:34:48+0530] [ALPM] removed noto-fonts-compat (20151217-1)
[2022-08-21T14:34:48+0530] [ALPM] removed manjaro-base-skel (20171029-3)
[2022-08-21T14:34:49+0530] [ALPM] removed kinfocenter (5.24.6-1)
[2022-08-21T14:34:49+0530] [ALPM] removed xorg-xdpyinfo (1.3.3-4)
[2022-08-21T14:34:49+0530] [ALPM] removed wayland-utils (1.0.0-2)
[2022-08-21T14:34:49+0530] [ALPM] removed vulkan-tools (1.3.217-1)
[2022-08-21T14:34:49+0530] [ALPM] removed kgamma5 (5.24.6-1)
[2022-08-21T14:34:49+0530] [ALPM] removed systemsettings (5.24.6-3)
[2022-08-21T14:34:49+0530] [ALPM] removed sddm-breath-theme (21.3.0-4)
[2022-08-21T14:34:50+0530] [ALPM] removed powerdevil (5.24.6-1)
[2022-08-21T14:34:50+0530] [ALPM] removed plasma-pa (5.24.6-1)
[2022-08-21T14:34:50+0530] [ALPM] removed plasma-nm (5.24.6-1)
[2022-08-21T14:34:50+0530] [ALPM] removed networkmanager-qt (5.96.0-1)
[2022-08-21T14:34:50+0530] [ALPM] removed modemmanager-qt (5.96.0-1)
[2022-08-21T14:34:50+0530] [ALPM] removed plasma-browser-integration (5.24.6-1)
[2022-08-21T14:34:51+0530] [ALPM] removed khotkeys (5.24.6-1)
[2022-08-21T14:34:52+0530] [ALPM] removed kdelibs4support (5.96.0-1)
[2022-08-21T14:34:53+0530] [ALPM] removed kemoticons (5.96.0-1)
[2022-08-21T14:34:53+0530] [ALPM] removed kdeplasma-addons (5.24.6-1)
[2022-08-21T14:34:53+0530] [ALPM] removed kunitconversion (5.96.0-1)
[2022-08-21T14:34:54+0530] [ALPM] removed plasma-workspace (5.24.6-1)
[2022-08-21T14:34:54+0530] [ALPM] removed xorg-xsetroot (1.1.2-3)
[2022-08-21T14:34:54+0530] [ALPM] removed xorg-xmessage (1.0.6-1)
[2022-08-21T14:34:54+0530] [ALPM] removed libxaw (1.0.14-1)
[2022-08-21T14:34:54+0530] [ALPM] removed prison (5.96.0-2)
[2022-08-21T14:34:54+0530] [ALPM] removed libdmtx (0.7.7-1)
[2022-08-21T14:34:54+0530] [ALPM] removed plasma-integration (5.24.6-1)
[2022-08-21T14:34:54+0530] [ALPM] removed ttf-hack (3.003-3)
[2022-08-21T14:34:54+0530] [ALPM] removed libqalculate (4.2.0-1)
[2022-08-21T14:34:54+0530] [ALPM] removed kio-fuse (5.0.1-1)
[2022-08-21T14:34:54+0530] [ALPM] removed kholidays (1:5.96.0-1)
[2022-08-21T14:34:55+0530] [ALPM] removed kde-cli-tools (5.24.6-1)
[2022-08-21T14:34:55+0530] [ALPM] removed kdesu (5.96.0-1)
[2022-08-21T14:34:55+0530] [ALPM] removed kactivitymanagerd (5.24.6-1)
[2022-08-21T14:34:55+0530] [ALPM] removed kactivities-stats (5.96.0-1)
[2022-08-21T14:34:55+0530] [ALPM] removed appstream-qt (0.15.4-1)
[2022-08-21T14:34:55+0530] [ALPM] removed appstream (0.15.4-1)
[2022-08-21T14:34:55+0530] [ALPM] removed accountsservice (22.08.8-2)
[2022-08-21T14:34:55+0530] [ALPM] removed libpamac-flatpak-plugin (11.3.1-1)
[2022-08-21T14:34:55+0530] [ALPM] removed pipewire-alsa (1:0.3.56-1.0)
[2022-08-21T14:34:56+0530] [ALPM] removed kwin (5.24.6-1)
[2022-08-21T14:34:56+0530] [ALPM] removed libqaccessibilityclient (0.4.1-2)
[2022-08-21T14:34:56+0530] [ALPM] removed kwayland-server (5.24.6-1)
[2022-08-21T14:34:56+0530] [ALPM] removed breeze (5.24.6-1)
[2022-08-21T14:34:57+0530] [ALPM] removed breeze-icons (5.96.0-1)
[2022-08-21T14:34:58+0530] [ALPM] removed flatpak (1:1.12.7-1)
[2022-08-21T14:34:58+0530] [ALPM] removed ostree (2022.5-2)
[2022-08-21T14:34:58+0530] [ALPM] removed xdg-desktop-portal (1.15.0-1)
[2022-08-21T14:34:58+0530] [ALPM] removed geoclue (2.6.0-2)
[2022-08-21T14:34:58+0530] [ALPM] removed geocode-glib (3.26.4-1)
[2022-08-21T14:34:58+0530] [ALPM] removed telegram-desktop (4.1.0-1)
[2022-08-21T14:34:58+0530] [ALPM] removed ttf-opensans (1.101-2)
[2022-08-21T14:34:58+0530] [ALPM] removed rnnoise (0.4.1-1)
[2022-08-21T14:34:58+0530] [ALPM] removed qt6-wayland (6.3.1-1)
[2022-08-21T14:34:58+0530] [ALPM] removed qt6-imageformats (6.3.1-1)
[2022-08-21T14:34:58+0530] [ALPM] removed qt6-5compat (6.3.1-1)
[2022-08-21T14:34:58+0530] [ALPM] removed libdispatch (5.5.0-1)
[2022-08-21T14:34:58+0530] [ALPM] removed jemalloc (1:5.3.0-1)
[2022-08-21T14:34:59+0530] [ALPM] removed abseil-cpp (20220623.0-1)
[2022-08-21T14:34:59+0530] [ALPM] removed pipewire-media-session (1:0.4.1-2)
[2022-08-21T14:34:59+0530] [ALPM] removed pipewire (1:0.3.56-1)
[2022-08-21T14:34:59+0530] [ALPM] removed alsa-card-profiles (1:0.3.56-1)

Now what should I do to bring my login screen back to the original?

the date is 2022-08-21 when you removed all of the stuff, it is correct? but it has to be, looking at the removed packages … are you in chroot now?

Yes the date is correct I had removed my pipewire that day but due to some work I didn’t had the time to fix it. I am not in chroot I managed to login in the terminal and restored pipewire, so now I am in the system. The only thing now that is left to do is the login screen during startup is still as the photo which I provided in my question. How do I bring back to the original

Install (at least) the following:

pamac install manjaro-kde-settings plasma

1 Like

Thank you it returned to the normal login screen.