Can't login to Manjaro even with correct password

I ran a startx command with administrative privileges. After that system starts with root account.
Then i restarted system.
But after entering password, login screen goes black for 1 sec and again shows me login screen.

Someone told me to create new user account via single user mode and login with that. But that trick doesn’t works.

So you run sudo startx ?
X creates a file called .Xauthority in your home folder. I guess in /root there must be such a file now. Please check it.

1 Like

Apologies for late reply.
Yes there is a file named xauthority in root directory.

I guess that is your problem. Remove the file or purge the home directory of root. Never run startx as root again.

Let me try boss

Sorry boss. Still not working.

1st image

[2nd image ](

At 1st image. It is before removing Xauthority

And 2nd one is after purging Xauthority

(Single user mode)

Sorry @pradeepthedemon , but the links are not public. :man_shrugging:

It is not really clear how you normally login. Please explain… normally one would use a display-manager.

I logged in via single user mode. As per your suggestion i remove that file.

Now after restarting system when I login in single user mode.

I greated with few errors

  • /bin/bash doesn’t exist
  • ss can’t access tty. Job control turned off.
  • home directory is missing

And problem still exists

So you are aware that this mode means that you are root and any program can mess with any file without restrictions? It is also called “emergency” oder “maintenance” mode on run level 1.

X is not made to be run in that mode or any graphical applications.

That looks like you are still on the initcpio image and didn’t switch the actual filesystem for some unknown reason.

Unfortunately but yes…

Are you on Gnome ?

But after entering password, login screen goes black for 1 sec and again shows me login screen

That’s very suspicious to me

It’s cinnamon gnome’s fork