Can't login to desktop

So, I can’t login to my main desktop. I try to boot up, the login screen appears, I type the password and the screen freezes forever.

  • If I enter an incorrect password, it doesn’t freeze and just prompts me to enter the correct one.

  • If I enter the correct password it freezes and I have to restart my computer.

  • I am able to login into my root user and that desktop.

  • My home directory has it’s own partition and so does the root directory. I have a boot partition and a swap partition as well.

  • I’m using rEFInd boot manager because I dual boot with Windows.

I’ve looked this question up and responses to it before have not been helpful. Those questions usually end up with “oops, I didn’t have any space” - but, space for what? Idk. I’ve checked my partitions and none of them are at capacity storage-wise. This is a relatively new system. I haven’t been using Linux for long.

Alternatively, they end in “nvm, I figured it out” or someone typing a response that looks like total gibberish to me and the asker being like “omg, that worked!” As you can imagine, that’s not very helpful for me.

An explanation I’ve seen is it being something with the drivers not being right or something. Idk how to check which drivers I’m using.

In a lot of descriptions, this issue has also occurred after an update.

  • I updated every package that needed to be updated the last time I was on the desktop that I’m currently unable to log into.

So, I’m thinking it might have something to do with that. The problem is that I don’t know how to figure out which update caused the problem (or how to downgrade packages). It was quite a lot of packages that I updated.

One of the first issues I read about it potentially being was something about the Linux Kernel. So, I installed the 5.4 LTS release and booted into that, but I just got a black screen. So, I installed the 5.11 release and booted into that and it worked normally - with the same login screen problem. I was originally on 5.10.

Long story short, I need some real help.

Can you just type out any code that needs to be put into the terminal in your solutions, as well? Because, I won’t get it if you just say “update the 1wbj4j012jnn0 file and then run the 12infisqnfn7iubf script” or whatever.

1 Like

Can you provide more information about the system? Hardware, video card, desktop environment (KDE? GNOME? Xfce?)

When you say “freeze”, how long did you wait for? I know it sounds silly, but there’s a bug in upstream KDE that will eventually log you in after 3 minutes or so of waiting (when it appears your system froze). They’re currently trying to fix this particular bug, which might have nothing to do with your situation.

When it freezes, are you able to press CTRL + ALT + F2 to switch to a TTY screen that lets you login with a terminal?

No. Pressing Ctrl + Alt + F2 doesn’t do anything on login screen.

After a long while of waiting it eventually just shuts down.

512 PCe SSD, Intel Iris Xe graphics (integrated). I’m using KDE Plasma.

If you hold down ESC or LEFT SHIFT to interrupt the boot process, are you able to display the Grub boot menu screen? Can you select “Advanced options” and boot into a “fallback” mode? If so, does that allow you to login to your desktop?

Were you doing this after the problem occured? From a TTY screen?

No, I can still log into my root desktop. So, I wash changing the kernel in root to try to fix it.

I’ll check real quick about interrupting the boot process.

As the user “root”?

Try the fallback option above, and if it doesn’t work, you can try this, but being VERY VERY VERY VERY VERY careful not to enter the wrong command.

When you’re logged in as the root user, open up a terminal and type:

mv -v /home/winnie/.cache /home/winnie/.cache.bak

Replace winnie with your actual username. This will rename your user’s cache folder, which forces a new, fresh one to be created. It can rule out some of these issues. Since you’re only renaming it, you’re not destroying the actual folder.

Reboot and try logging in with your actual user account.

Make sure you try it with both LEFT (CTRL + ALT) if the RIGHT ones don’t work.

Having the exact same issue as OP, starting around the time it was posted actually.
Anyways, if our issues are the same, I can tell you that yes, I can login via tty2, and I can also say that renaming the cache as the root user didn’t do anything to resolve the issue.
I can provide slightly more info, I noticed when going into advanced options in GRUB, and pressing f10 to boot from there, it gave an error in the top left of a black screen before bringing me to the login GUI. I also saw this once before trying to get to the screen normally. Although I cant get it to reliably pop up again, it was" Failed to start user login management"

Edit: spelling
"

1 Like