Can't login to desktop after vnc session

Hi all.

I installed tigerVNC on my XFCE manjaro system alongside x11vnc. Please note that this is not a headless connection- it is a physical laptop.

I was able to successfully setup a VNC connection over LAN through localhost:5900. At one point though, I believe I ran “x0vncserver” at the same time as I ran “x11vnc” which resulted in it running on another port “localhost:5901” , but I am not sure if this contributes to my issue.

After testing out the vnc on my Mac, I exited the session, and returned to my physical laptop only to find that I could not type anything in the terminal. Certain things did show up when I typed letters such as “a”, I believe it was “^” and some other commands. The mouse was not working at all.

So I shut down my laptop using the power button, and get to the Manjaro login screen. every thing looks normal, the keyboard is working fine with the mouse, but after entering in the correct password I am greeted with my startup screen “Lenovo logo” and returned back to the login page.

I have tried to TTY into the system and set the DISPLAY variable to 0:0, but this does not change anything when I try to sign in again through the GUI login. I’ve uninstalled tigervnc, x11vnc, still no luck. It seems like the system does not recognize my display.

Something with my X is definitely messed up, I’m not sure if this is related to xauth?

Hello, can somebody help?

Someone may be able to assist if you posted some info on what you did to set up these two vnc servers
how you ran and used them - after which you where not able to log in anymore
… what advice did you follow, what guide, perhaps …
You could also have a look into the logs that are created by these two - or in the system logs.
And you could check for proper permissions on files in your $HOME directory - nothing there should be owned by anyone else than your user.
Use a TTY to do it - since you can’t login into your graphical session, apparently.

Without any info this is all guesswork.
That is probably why no one did reply …

I have made edits. How do I look at the logs?

e.g. ~ = home

journalctl -xe
systemctl status lightdm.service

I always use these instructions for VNC with Lightdm (xfce)
i can use vnc and physical device at the same time. Login / logout is no problem either

Also, I used this guide

Could someone help who has used x0vncserver or x11vnc?

Hi @noyou34,

I am 100% sure I don’t know how to fix it. I do, however, think I know what’s happening, although I might actually not be correct.

I suspect when you connected your keyboard layout was changed.

I don’t know how to fix it, but I suspect you’ll have to do it from a live ISO. Possibly from a chroot environment. But I might be wrong.

Looks like you can check the keyboard layout from the command line with cat /etc/vconsole.conf:

$ cat /etc/vconsole.conf
1   │ KEYMAP=za
2   │ FONT=
3   │ FONT_MAP=

Edit 2:

According to the Arch wiki:

For convenience, localectl may be used to set console keymap. It will change the KEYMAP variable in /etc/vconsole.conf and also set the keymap for current session:

$ localectl set-keymap --no-convert *keymap*

The --no-convert option can be used to prevent localectl from automatically changing the Xorg keymap to the nearest match. See localectl(1) for more information.

Hope this helps!