Can't load prior version of Manjaro

So, I’ve had problems with the latest version of Manjaro KDE 24, mainly that Remmina and Latte Dock aren’t working. So now I’m trying to go back and install version 23 again, but can’t get past part where it asks whether you want to use open source drivers or proprietary. Screen just goes black. I’ve never had this problem before. Has version 24 screwed up the system so that one can no longer go back if desired? Thanks in advance for any help

Hi @Reno232,

Your post is blank, so there’s really no way to know what the problem is.

However, I will tell you that Manjaro’s “versions” are actually all the same as the current, stable one for that moment. You just need to keep your system up-to-date and you have the latest, and actually only supported version.

Therefore, partial updates aren’t supported. So that might be the reason for your trouble. But there’s no way to be sure without more information.


Has been discontinued a heck of as long time ago, so it probably still uses the qt5 framework, while this update brought qt6.

I’ve just installed it and it works fine. How did you install it?

First, thanks for the info on Latte Dock. Sad to hear, although it worked fine with the last version. Second, I ended up changing the passcode for Remmina and now it works, so that was a little funky, but it works now.

Third, I always install all the updates, never partial, that’s why this was a little perplexing. And lastly, even though it’s no longer an issue, I wonder why I was unable to install the earlier version? As stated, no longer an issue, but a little disconcerting none the less.

1 Like

If you ever find it necessary to roll back an update again, there is only one sensible way to do it:

Timeshift! (or snapper)

A new installation inevitably leads to the need to install the updates. Especially if the ISO does not contain all the necessary programs.

If you then try to install these programs with pacman -S paket-x, the system is already in a partial update status. The installed programs are then newer than the underlying system.

This is not good at all. So no solution.

On the other hand, with timeshift you can go back to a completely consistent state. Everything then works as it did the day before the update.

Of course you have to update sooner or later, but you have

  • a running system
  • Time to read up on what could be the reason
  • The opportunity to try again
  • If necessary, timeshift (or snapper) again


Your question has already been answered; Latte Dock:

So, to expand on that; Latte Dock works on the Qt5 framework (Plasma 5) but does not work with the new Qt6 framework (Plasma 6). As the Latte Dock developer has abandoned the project Latte Dock | Farewell… there is also unlikely to be an updated version.

It is recommended to uninstall Latte Dock, and then remove all residual traces:

sudo pacman -R latte-dock
rm -rf ~/.config/latte

…and reboot.

Leaving these traces may cause minor rendering issues, such as panel context menus appearing in the centre of the screen, for example.

I hope this clarification is helpful. Cheers.


Great suggestion, thank you