Can't load Nvidia drivers on fresh installation

Brand new to Manjaro and pretty new to linux (Been on Kali for a bit).

Got a new work laptop and want to use Manjaro as my daily driver for work.
I have reinstalled Manjaro ~30+ times at this point and I’ve spent days trying to figure this out. I’ve been through the wiki exhaustively and tried everything I can to fix it.

I normally don’t ever ask for help on things like this as I can typically research it, but, I am now asking for help as I’m at a loss.

Hybrid Intel/Nvidia (I hate hybrids but I didn’t buy the laptop so I don’t have a choice)

sudo mhwd -a pci nonfree 0300

I cannot run the above command because it will brick my system (Unable to get to terminal with CTRL+ALT F1,F2,F3,F4,F5,F6)

According to the hardware configuration
It “wants” to install video-hybrid-intel-nvidia-prime

Thats the one that bricks the system

So I naturally tried the option below

Since I have to boot with open-source drivers

I run this first before installing and restarting laptop

sudo mhwd -r pci video-linux

I then run

sudo mhwd -i pci video-hybrid-intel-nvidia-470xx prime

It installs but it won’t load.

inxi -G                                                                                   
  Device-1: Intel Alder Lake-HX GT1 [UHD Graphics 770] driver: i915 v: kernel
  Device-2: NVIDIA GA107GLM [RTX A1000 Laptop GPU] driver: N/A
  Device-3: Acer Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: modesetting
    dri: iris gpu: i915 resolution: 1920x1200~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel UHD Graphics (ADL-S

I suspect the issue may lie in the modules section and configuring it to load early from my research but the only research i’ve found on it so far is related to AMD and there aren’t any suggestions for Nvidia on that topic.

inxi -fazy                                                                                
  Info: model: 12th Gen Intel Core i9-12950HX bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 2
    microcode: 0x26
  Topology: cpus: 1x cores: 16 mt: 8 tpc: 2 st: 8 threads: 24 smt: enabled
    cache: L1: 1.4 MiB desc: d-8x32 KiB, 8x48 KiB; i-8x32 KiB, 8x64 KiB
    L2: 14 MiB desc: 8x1.2 MiB, 2x2 MiB L3: 30 MiB desc: 1x30 MiB
  Speed (MHz): avg: 2367 high: 2500 min/max: 800/4900:5000:3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2500 2: 2500 3: 2500
    4: 898 5: 2500 6: 2500 7: 2500 8: 2500 9: 2500 10: 2500 11: 2500 12: 2500
    13: 2500 14: 2500 15: 918 16: 2500 17: 2500 18: 2500 19: 2500 20: 2500
    21: 2500 22: 2500 23: 2500 24: 2500 bogomips: 119832
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe
    movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid
    pclmulqdq pconfig pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdpid rdrand rdseed rdtscp rep_good sdbg sep serialize sha_ni smap smep
    smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall
    tm tm2 tme tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq
    umip vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
mhwd -li                                                                                      
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

I’ve even tried installing the linuxx64 drivers that are downloaded directly from their page using sudo bash but I get some weird error when its building it and its unable to finish installing.

I have developed an unhealthy obsession with fixing this lol.

I have fixed touchpad driver issues, sound driver issues and network issues but I can’t get these drivers to load properly.

I also have NO output on HDMI port to one monitor with the Open source drivers at all.

So hopefully the proprietary drivers after they are loaded will fix that display issue as well.

I appreciate your time on this

see this

Thank you very much. I got it working and then used optimus manager to swap over to nvidia

KDE Users remember to edit /etc/sddm.conf (sudo nano /etc/sddm.conf)

and add # to both DisplayCommand and DisplayStopCommand to get optimus manager working


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.