Can't launch softwares, then desktop get stuck

Hi,
I am new to manjaro from ubuntu, it’s a great distro, thank you guys great work and enthusiasm.

But I recently met the same problem that bothers me when I was using ubuntu, which is I usually failed to launch many softwares, it tells me the program is running but no responding. when I launch KSysGuard to check the stuck program, it shows “disk sleep”, and then the whole desktop stuck in no responding.

May I have your help to check where is wrong and how can I solve it? I would be so appreciated.

I am using manjaro kde plasma 5.21.1, the kernel version is 5.19.6-1-MANJARO

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  3. Are you a time traveller?

    • If yes, please wait until the rest of the world is on kernel 5.19 as well as the most recent kernel in our timeline is 5.12RC2.
    • if no, the output from #2 above should bring some clarity! :grin:
  4. Please also post the output of:

    smartctl --all /dev/sda
    

    as your HDD/SSD might be failing…

:+1:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

here is my ouput of inxi --admin --verbosity=7 --filter --no-host --width:

System:
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64
  root=UUID=3a174614-bf8b-4d2e-b5ad-67b3336652ed ro quiet apparmor=1
  security=apparmor resume=UUID=5b1cc1d4-4ea8-4c0a-811c-7bb4545c690b
  udev.log_priority=3
  Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM
  Distro: Manjaro Linux
Machine:
  Type: Convertible System: HP product: HP ENVY x360 Convertible 15-cn1xxx
  v: Type1ProductConfigId serial: <filter> Chassis: type: 31 serial: <filter>
  Mobo: HP model: 850D v: 70.76 serial: <filter> UEFI: Insyde v: F.22
  date: 11/26/2019
Battery:
  ID-1: BAT0 charge: 51.1 Wh condition: 51.1/51.1 Wh (100%) volts: 13.0/11.6
  model: 333-54-5D-A LK03055XL type: Li-ion serial: <filter> status: Full
  Device-1: hid-0018:04F3:272A.0001-battery model: ELAN0732:00 04F3:272A
  serial: N/A charge: N/A status: N/A
Memory:
  RAM: total: 15.34 GiB used: 3.08 GiB (20.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: B (11)
  microcode: DE L2 cache: 6 MiB bogomips: 28808
  Speed: 795 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 795 2: 793 3: 797
  4: 793 5: 800 6: 800 7: 798 8: 783
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb erms est f16c
  flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify
  ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear
  mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
  pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed
  rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3
  stibp syscall tm tm2 tsc tsc_adjust tsc_deadline_timer vme x2apic xgetbv1
  xsave xsavec xsaveopt xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
  v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0 class ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX150] driver: nvidia v: 460.56
  alternate: nouveau,nvidia_drm bus ID: 02:00.0 chip ID: 10de:1d10
  class ID: 0302
  Device-3: Quanta HP Wide Vision HD Camera type: USB driver: uvcvideo
  bus ID: 1-4:4 chip ID: 0408:5300 class ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver:
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa
  display ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2")
  s-diag: 581mm (22.9")
  Monitor-1: DP-1 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6")
  diag: 546mm (21.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
  alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:9dc8
  class ID: 0403
  Sound Server: ALSA v: k5.9.16-1-MANJARO
Network:
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel
  port: 4000 bus ID: 00:14.3 chip ID: 8086:9df0 class ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8152 Fast Ethernet Adapter type: USB driver: r8152
  bus ID: 1-2.4:7 chip ID: 0bda:8152 class ID: 0000 serial: <filter>
  IF: enp0s20f0u2u4 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
  driver: btusb v: 0.8 bus ID: 1-10:6 chip ID: 8087:0aaa class ID: e001
  Message: Required tool hciconfig not installed. Check --recommends
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
  v: 3.0 port: 4060 bus ID: 00:17.0 chip ID: 8086.282a rev: 30
Drives:
  Local Storage: total: 931.51 GiB used: 190.71 GiB (20.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M81000G
  size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 rotation: SSD serial: <filter> rev: S5Z42105 temp: 27.9 C
  scheme: GPT
  Message: No Optical or Floppy data was found.
Partition:
  ID-1: / raw size: 914.34 GiB size: 898.99 GiB (98.32%)
  used: 190.71 GiB (21.2%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: 3a174614-bf8b-4d2e-b5ad-67b3336652ed
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%)
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
  uuid: A75F-0E13
  ID-3: /run/timeshift/backup raw size: 914.34 GiB size: <superuser required>
  used: <superuser required> fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: 3a174614-bf8b-4d2e-b5ad-67b3336652ed
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16.88 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
  uuid: 5b1cc1d4-4ea8-4c0a-811c-7bb4545c690b
Unmounted:
  Message: No Unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900
  Device-1: 1-1:2 info: SINOWEALTH Game Mouse type: Mouse,Keyboard
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
  chip ID: 258a:0017 class ID: 0301
  Hub-2: 1-2:3 info: Realtek RTS5411 Hub ports: 4 rev: 2.1 speed: 480 Mb/s
  chip ID: 0bda:5411 class ID: 0900
  Device-1: 1-2.1:5 info: A4Tech USB Keyboard type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s
  chip ID: 09da:2268 class ID: 0300
  Device-2: 1-2.4:7 info: Realtek RTL8152 Fast Ethernet Adapter type: Network
  driver: r8152 interfaces: 1 rev: 2.1 speed: 480 Mb/s chip ID: 0bda:8152
  class ID: 0000 serial: <filter>
  Device-3: 1-4:4 info: Quanta HP Wide Vision HD Camera type: Video
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 0408:5300
  class ID: 0e02 serial: <filter>
  Device-4: 1-10:6 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP)
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
  chip ID: 8087:0aaa class ID: e001
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s
  chip ID: 1d6b:0003 class ID: 0900
  Hub-4: 2-2:2 info: Realtek Hub ports: 4 rev: 3.0 speed: 5 Gb/s
  chip ID: 0bda:0411 class ID: 0900
Sensors:
  System Temperatures: cpu: 43.0 C mobo: 40.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 269 Uptime: 1h 33m wakeups: 19 Init: systemd v: 247 Compilers:
  gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1741 lib: 444 flatpak: 0
  Shell: Zsh v: 5.8 running in: alacritty inxi: 3.3.01

and the output of smartctl -all /dev/nvme0, I am using single SSD,

=== START OF INFORMATION SECTION ===
Model Number:                       KINGSTON SA2000M81000G
Serial Number:                      50026B7683C443C2
Firmware Version:                   S5Z42105
PCI Vendor/Subsystem ID:            0x2646
IEEE OUI Identifier:                0x0026b7
Controller ID:                      1
NVMe Version:                       1.3
Number of Namespaces:               1
Namespace 1 Size/Capacity:          1,000,204,886,016 [1.00 TB]
Namespace 1 Utilization:            407,875,637,248 [407 GB]
Namespace 1 Formatted LBA Size:     512
Namespace 1 IEEE EUI-64:            0026b7 683c443c25
Local Time is:                      Thu Mar 11 13:06:24 2021 CST
Firmware Updates (0x14):            2 Slots, no Reset required
Optional Admin Commands (0x0017):   Security Format Frmw_DL Self_Test
Optional NVM Commands (0x005f):     Comp Wr_Unc DS_Mngmt Wr_Zero Sav/Sel_Feat Timestmp
Log Page Attributes (0x0f):         S/H_per_NS Cmd_Eff_Lg Ext_Get_Lg Telmtry_Lg
Maximum Data Transfer Size:         32 Pages
Warning  Comp. Temp. Threshold:     75 Celsius
Critical Comp. Temp. Threshold:     80 Celsius

Supported Power States
St Op     Max   Active     Idle   RL RT WL WT  Ent_Lat  Ex_Lat
 0 +     9.00W       -        -    0  0  0  0        0       0
 1 +     4.60W       -        -    1  1  1  1        0       0
 2 +     3.80W       -        -    2  2  2  2        0       0
 3 -   0.0450W       -        -    3  3  3  3     2000    2000
 4 -   0.0040W       -        -    4  4  4  4    15000   15000

Supported LBA Sizes (NSID 0x1)
Id Fmt  Data  Metadt  Rel_Perf
 0 +     512       0         0

=== START OF SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

SMART/Health Information (NVMe Log 0x02)
Critical Warning:                   0x00
Temperature:                        27 Celsius
Available Spare:                    100%
Available Spare Threshold:          10%
Percentage Used:                    0%
Data Units Read:                    7,101,160 [3.63 TB]
Data Units Written:                 14,386,909 [7.36 TB]
Host Read Commands:                 106,458,323
Host Write Commands:                385,337,572
Controller Busy Time:               3,538
Power Cycles:                       973
Power On Hours:                     2,143
Unsafe Shutdowns:                   237
Media and Data Integrity Errors:    0
Error Information Log Entries:      0
Warning  Comp. Temperature Time:    0
Critical Comp. Temperature Time:    0

Error Information (NVMe Log 0x01, 16 of 256 entries)
No Errors Logged
  1. You’re on 5.9: that’s an EOL kernel: add both 5.4 LTS and 5.10 LTS and try both and report back, please?
  2. :sweat_smile: :+1:
    That looks good!

:wink:

I have’been switched to kernel 5.4, but it seems getting worse. Every time I startup my computer it will stuck in no responding, I have to using power button to shut down, and restart a few times to get it work normally. should I switch back to 5.9? Thanks for your patient

(emphasis mine)

Please read this:

:scream: