Can't install XanMod kernel - complains about openssl and then libelf and elfutils

I’m trying to install XanMod in two ways:

  • pamac build linux-manjaro-xanmod
  • makepkg -s after downloading the package.
    The problems were multiple, first there was a PGP problem which I solved (it seems), then an openssl problem which I kind of solved with export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig, now the problem I get is the following:
    -makepkg -s exits in patching file virt/kvm/coalesced_mmio.c error in prepare() exit
    and pamac ends with:

error: Cannot generate ORC metadata for CONFIG_UNWINDER_ORC=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel

and then with:


home/denijane/anaconda3/bin/../lib/gcc/x86_64-conda_cos6-linux-gnu/7.3.0/../../.-./../x86_64-conda_cos6-linux-gnu/bin/ld: /usr/lib/openssl-1.0/libcrypto.so: undefined reference to `secure_getenv@GLIBC_2.17'
collect2: error: ld returned 1 exit status
make[1]: *** [scripts/Makefile.host:95: scripts/sign-file] Грешка 1
make[1]: ••• Изчакване на незавършени задачи…
/home/denijane/anaconda3/bin/../lib/gcc/x86_64-conda_cos6-linux-gnu/7.3.0/../../../../x86_64-conda_cos6-linux-gnu/bin/ld: /usr/lib/openssl-1.0/libcrypto.so: undefined reference to `memcpy@GLIBC_2.14'
/home/denijane/anaconda3/bin/../lib/gcc/x86_64-conda_cos6-linux-gnu/7.3.0/../../../../x86_64-conda_cos6-linux-gnu/bin/ld: /usr/lib/openssl-1.0/libcrypto.so: undefined reference to `secure_getenv@GLIBC_2.17'
collect2: error: ld returned 1 exit status
make[1]: *** [scripts/Makefile.host:95: scripts/extract-cert] Грешка 1
  HOSTLD  scripts/genksyms/genksyms
make: *** [Makefile:1226: scripts] Error 2
==> ERROR: Failure in build(). 

I installed libelf and elfutils, I’m not sure what the problem is and googling it wasn’t helpful. Everybody says that installing libelf-dev, libelf-devel or elfutils-libelf-devel helps but for Manjaro I believe there is only libelf and elfutils and I installed them and still, it doesn’t work. So yeah, and ideas are welcome.

And on a side note, does anybody knows which version of binutils works witch gcc 11.1. I have binutils 2.36 but I know the latest version never works properly.

Tip: When pasting terminal output on Discourse forums, one can either…

  • Highlight it and use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):

    ```
    text
    ```

  • Use HTML:

    <pre><code>
    text
    </pre></code>

Please edit your post accordingly.

Ok, I formatted it. But I don’t see how this helps. I don’t mean it in a rude way, but I badly need a reliable kernel which will wakeup from suspend normally and which will not crash randomly. And I spent the whole day trying to install this one and it’s a bit disappointing.

The marking of code makes the output readable.

From your output, you’re not using the system’s gcc but one coming from anaconda, specifically version 7.3.0. Can you try with the system’s gcc?

I have this problem for a lot of things, which use the conda installation instead of the default linux bins. Do you know how to change that?
Edit: I found out how to do it:
conda deactivate

Ok, I installed it with conda desactivated, but it does the same as 5.13 (probably logically, since I installed the 5.13 xanmod) - when it wakes up from suspend, it shows logout screen upon every key strike. So not very functional. But at least it installed. So thanks for the replies, they actually helped.

I guess rather than installing different kernels with random patches, you’ll be probably better off in finding the actual issue.
If your problem exists in all theses kernels then it’s maybe not a kernel problem but something else.

Well, I tried exporting the acpi tables, but the ssdt table is full of errors. My idea was to edit the table to allow s3 sleep and be done with it (if it works). Apart from that, I don’t know what to do - it seems to be a problem related to amdgpu and/or its coexistence with the nvidia discrete card. I’m not sure how to track down the issue.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.