Can't Install Windows 10 from USB for Dual-Boot-Setup

Dear manjaro fellows, I am having difficulties setting up my dual-boot.

Please notice: I am not very experienced with manjaro. Feel free to talk to me like I am 5 years old to avoid any confusion on my end :slight_smile:

PC/Background: In February 2020 I bought my very first desktop pc and decided to go with manjaro from the get go. Everything worked perfectly and I was very happy in my manjaro kingdom. However my inner piece got disrupted as I started going to university in october :frowning: I will need Windows for university in February (and also for gaming with anticheat clients).

  • CPU: AMD Ryzen 5 3600, 6x 3.60GHz
  • Mainboard: MSI X470 Gaming Plus Max
  • SSD: Silicon Power P34A80 1TB, M.2
  • GPU: Nitro+ Radeon RX 5700 XT 8G, 8GB GDDR6

My Plan: After research I wanted to install windows on a separate SSD so I bought another Silicon Power SSD with 2TB. After installing windows my plan was to update grub so I can choose the OS on startup.

The problem: I disconnected the existing SSD and connected the new SSD. I made a bootable Windows-10-USB with Windows Media Creation Tool. I plugged in the USB and started the CPU. Windows Installation showed up, I entered the product key. Then the new SSD wasn’t showing up/wasn’t recoignized as installation location. I searched the internet and found it as common problem with my mainboard. I manually added the drivers for finding the SSD to the USB-Stick. But, when I boot with the USB now nothing but a black screen comes up. The monitor starts and shows nothing but a blank screen the whole time.

What I tried:

  • I made a new bootable USB, twice with Windows Media Creation Tool, once with Rufus
  • I switched the USB-Stick in the process
  • I tried every video port on my gpu and mainboard because I thought the video output could have changed
  • I wanted to go to UEFI/BIOS but - as nothing shows up besides a black screen - there wasn’t an option to do it
  • I searched the web for the “usb boot windows 10 new pc” problem. It wasn’t very helpful. Some mentioned removing/resetting the CMOS battery but I didn’t want to do that - as I can’t understand the consequences

Where I stand now: I disconnected my new SSD and reconnected my old SSD and returned to my perfectly working manjaro (during this process I noticed the boot menu option doesn’t show up on starting in this constellation as well).

I hope there is a potentially easy fix to my problem because: Isn’t it like a have a brand new cpu and want to install Windows 10 for the first time? Why is the bootable USB not recognized anymore? This problem exceeds my skills :frowning:

AFAIK your new SSD not showing up in Win10 LiveUSB is not a Manjaro issue.
You may use your Manjaro to check whether your SSD is fine, but besides that, you’ll likely find more help on a Windows support forum.


Try out things:

  • You can boot your Manjaro from existing SSD–> also connect new SSD. Can you see the SSD in your disk partitioning app (e.g. Gnome Disks or GParted or KDE Partition Manager)? → Yes: The SSD works No: Here we go. Try the thing in a different PC or USB-enclosure if it works at all

  • If you can see the SSD from Manjaro while both are connected, can you start the Windows Installer and see the new SSD when both are connected?

  • Can you see the new SSD when you start a Manjaro installer from USB? (Then maybe install Windows on the old one and install Manjaro on the new one…you have got a backup of your personal files, don’t you?)

1 Like

Both my SSDs (old and new) are recognized in UEFI. The old one as an 1TB SSD, the new one as “Generic_NVME_Device”.

I can see the new SSD when starting a Manjaro installer from USB. The installer says that my new 2TB SSD only has 28GB of space. It also shows as 28gb SSD in the “/” folder.

I guess the new SSDs could be broken on arrival? Or is it to early to draw this conclusion?

It probably is broken. That happens with mass production. The greater the production numbers, the greater the amount of faulty devices that somehow slips through quality control.

Exactly, and that is why I’m afraid I’m going to have to close this thread. This is the official support forum for the Manjaro GNU/Linux distribution, not a Microsoft support forum, or an Apple support forum, or a BSD support forum, and so on.

@kandesbunzler, I am sorry, but you know the rules. Better ask your Windows support questions at the Microsoft support forum. After all, answering those questions is their job.