Can't install VPN - sites are blocked

I just installed Manjaro and went to set up a VPN. I used firefox and opera to open several sites and they are blocked. I get this message:

Unable to connect

Firefox can’t establish a connection to the server at wwwdotvpnmentordotcom.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

It seems to be blocking certain sites and they all have something to do with VPNs. Please help.

Please talk to your VPN provider.

Most likely it has something to do with your DNS - which again is related to your VPN configuration - most VPN’s are paid services - so talk to your VPN provider’s support channel.

1 Like

I don’t have a VPN provider. It seems like manjaro is blocking access to VPN sites.

No - Manjaro does not block anything - Manjaro does not care about your habits or your data - this is all yours to keep.

You have most likely fiddled with your DNS setup and if not then the webservers in question may be offline - shortly - or you have a routing issue.

Or you are in a country which disallows access to VPN in order to still be able to block your requests.

1 Like

They are likely blocked by your ISP. Though most of the time, this is done through their DNS, so you may gain access by setting a different DNS on your system.

I use express VPN on my mac with no problem. I’m using the same internet connection and thought it would be easier than this. I also signed up for Nord VPN but that is blocked too.

How do I set a different DNS?

I just tried to install windows 10 ISO and it failed a few times. Looks like I’m stuck with this. I made the mistake of erasing windows for linux. I tried to install brave browser and failed, tried to install a blulight blocker and it failed…VPN failed. I’m going insane now.

From your network settings.

Instead of telling "it’s failed’ please elaborate on that so that we can understand what went wrong.