Can't install snap firefox

Just before this happened, I have snap, flatpak, and extra firefox installed so whenever one crashes often, I’d just switch to different firefox. Recently, my snap firefox tabs often crashes. I can’t find the cause of it. I don’t know if its because of my laptop itself, the kernel I’m using, or I don’t know. Everything is up to date. I tried asking AI with GPT4, but didn’t solve my issue. I’m not that knowledgeable yet in linux but it is my daily driver.

I always get this error whenever I try to install snap firefox (will also attach screenshots below):

[user@user ~]$ sudo snap install firefox
[sudo] password for user: 
error: cannot perform the following tasks:
- Fetch and check assertions for snap "firefox" (3779) (cannot verify snap "firefox", no matching signatures found)

I also tried using the pamac GUI but nothing changed.

My laptop is ASUS X441UR, I use HDD.

I will attach a screenshot of my neofetch here incase its needed.
Mod edit: Removing text pictures.

A little offtopic because i do not use snaps and cannot help…but food for thought. Honestly…you would probably be better off using winboze…or at least ubuntu if you want to use snaps.
Maybe you should find out why are your browsers crashing at the first place?
Besides, you do not need 3 firefoxes…you can just start another instance with another user profile.
And last but not least - copy paste text instead of making a screenshot. And do not use neofetch, there is inxi for system info.


There is some services which needs to be active

systemctl enable --now snapd
systemctl enable --now snapd.apparmor

And snap install firefox is verified to be working. Albeit on a system which has never seen snap before - so there is that.

[user@user ~]$ systemctl enable --now snapd
[user@user ~]$ systemctl enable --now snapd.apparmor
[user@user ~]$ sudo snap install firefox
[sudo] password for user: 
error: cannot perform the following tasks:
- Fetch and check assertions for snap "firefox" (3779) (cannot verify snap "firefox", no matching signatures found)

nothing changed, as this point I’m actually thinking if having an old laptop is the cause. :frowning:

[user@user ~]$ neofetch
██████████████████  ████████   user@user 
██████████████████  ████████   --------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: X441URK 1.0 
████████            ████████   Kernel: 6.1.71-1-MANJARO 
████████  ████████  ████████   Uptime: 1 day, 2 hours, 42 mins 
████████  ████████  ████████   Packages: 1419 (pacman), 17 (flatpak), 15 (snap) 
████████  ████████  ████████   Shell: bash 5.2.21 
████████  ████████  ████████   Resolution: 1366x768, 1600x900 
████████  ████████  ████████   DE: Xfce 4.18 
████████  ████████  ████████   WM: Xfwm4 
████████  ████████  ████████   WM Theme: Matcha-sea 
████████  ████████  ████████   Theme: Matcha-dark-sea [GTK2/3] 
████████  ████████  ████████   Icons: Papirus-Maia [GTK2], Adwaita [GTK3] 
                               Terminal: xfce4-terminal 
                               Terminal Font: Monospace 12 
                               CPU: Intel i3-7100U (4) @ 2.400GHz 
                               GPU: Intel HD Graphics 620 
                               GPU: NVIDIA GeForce 930MX 
                               Memory: 6817MiB / 11847MiB
[user@user ~]$ inxi
CPU: dual core Intel Core i3-7100U (-MT MCP-) speed/min/max: 800/400/2400 MHz
Kernel: 6.1.71-1-MANJARO x86_64 Up: 1d 2h 44m Mem: 7.05/11.57 GiB (60.9%)
Storage: 465.76 GiB (37.0% used) Procs: 223 Shell: Bash inxi: 3.3.32

thanks for the tips! I didn’t know about inxi until now. :hushed:
I installed three firefox because sometimes while I’m using firefox, every tabs suddenly crashes. I can’t pin point the cause. I just switch kernel or switch to a different firefox. It fixes my problem temporarily but still can’t find the actual cause of the crash. I’m using the snap firefox for so long I think about 5 months or more then the crash suddenly happened.

so I tried to refresh it, but nothing changed, then tried to remove and install it again, this time I can’t install it back. so I’m currently using the official repository firefox. still crashing sometimes so might do the same back then if my firefox crash often. or might switch to flatpak temporarily and observe if the crash still persists. :frowning:


You are not alone - others have been there before you cannot verify snap “firefox”, no matching signatures found -

I am not using snap - I don’t intend to start - I did the test to satisfy my curiosity.

Programs crashing is often a sign of something deeper - if you have no swap and OOM killer is not enabled - then crashes occur more often.

systemctl enable --now systemd-oomd

Perhaps you could supply the textual response from

inxi -Fxxxc0
[user@user ~]$ inxi -Fxxxc0
  Host: user Kernel: 6.1.71-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 clocksource: tsc
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xscreensaver,xscreensaver-systemd vt: 7 dm: LightDM
    v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: X441URK v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X441URK v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends v: X441URK.314
    date: 02/28/2017
  ID-1: BAT0 charge: 28.8 Wh (100.0%) condition: 28.8/34.6 Wh (83.4%)
    volts: 10.8 min: 10.8 model: ASUSTeK ASUS Battery type: Li-ion serial: <serial-number>
    status: not charging cycles: 265
  Info: dual core model: Intel Core i3-7100U bits: 64 type: MT MCP
    smt: enabled arch: Amber/Kaby Lake note: check rev: 9 cache: L1: 128 KiB
    L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 2400 min/max: 400/2400 cores: 1: 2400 2: 2400 3: 2400
    4: 2400 bogomips: 19204
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-9.5 ports: active: DP-1,eDP-1 empty: HDMI-A-1,HDMI-A-2
    bus-ID: 00:02.0 chip-ID: <chip-id> class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce 930MX] vendor: ASUSTeK driver: nouveau
    v: kernel arch: Maxwell pcie: speed: 2.5 GT/s lanes: 4 bus-ID: 01:00.0
    chip-ID: <chip-id> class-ID: 0302
  Device-3: IMC Networks USB2.0 VGA UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-6:4 chip-ID: <chip-id>
    class-ID: 0e02 serial: <serial-number>
  Display: x11 server: X.Org v: 21.1.10 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: modesetting alternate: fbdev,vesa dri: iris,nouveau gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 2966x900 s-dpi: 96 s-size: 784x238mm (30.87x9.37")
    s-diag: 819mm (32.26")
  Monitor-1: DP-1 pos: left model: Acer P206H serial: <serial-number>
    res: 1600x900 hz: 60 dpi: 92 size: 443x249mm (17.44x9.8") diag: 508mm (20")
    modes: max: 1600x900 min: 720x400
  Monitor-2: eDP-1 pos: primary,right model: BOE Display 0x0644
    res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.17x6.81")
    diag: 354mm (13.9") modes: 1366x768
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: <chip-id>
    class-ID: 0403
  API: ALSA v: k6.1.71-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.0 status: off
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
    driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 02:00.0 chip-ID: <chip-id> class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <mac-address>
  Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
    vendor: AzureWave driver: rtl8821ae v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: c000 bus-ID: 03:00.0 chip-ID: <chip-id> class-ID: 0280
  IF: wlp3s0 state: up mac: <mac-address>
  Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 12 Mb/s lanes: 1 bus-ID: 1-8:5 chip-ID: <chip-id>
    class-ID: e001 serial: <serial-number>
  Report: hciconfig ID: hci0 rfk-id: 1 state: up address: N/A
  Local Storage: total: 465.76 GiB used: 172.24 GiB (37.0%)
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680
    size: 465.76 GiB speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <serial-number>
    fw-rev: A3B0 scheme: GPT
  ID-1: / size: 49.04 GiB used: 43.22 GiB (88.1%) fs: ext4 dev: /dev/sda3
  ID-2: /boot/efi size: 496 MiB used: 44.6 MiB (9.0%) fs: vfat
    dev: /dev/sda2
  ID-3: /home size: 159.48 GiB used: 128.97 GiB (80.9%) fs: ext4
    dev: /dev/sda4
  Alert: No swap data was found.
  System Temperatures: cpu: 72.0 C pch: 64.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 4400
  Memory: total: 12 GiB available: 11.57 GiB used: 7.68 GiB (66.4%)
  Processes: 218 Power: uptime: 1d 3h 12m states: freeze,mem,disk
    suspend: deep wakeups: 0 hibernate: platform Init: systemd v: 255
    default: graphical
  Packages: 1451 pm: pacman pkgs: 1419 pm: flatpak pkgs: 17 pm: snap
    pkgs: 15 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.21
    running-in: xfce4-terminal inxi: 3.3.32

thanks for noticing! I didn’t know my swap was turned off, I just checked in GParted now I right click and there is a button Swapon. I currenly have 3 operating system installed in my HDD. two linux and one windows, its on multiboot. I just Swapon the swap partition in my other distro too and the distro that I’m currently using right now and my primary distro which is Manjaro also reads the swap of the other one?

my swap for each distro is 2GB, I have enough memory I think? that’s why I only made my swap that way, is it enough? or I need to resize and extend it?

[user@user ~]$ free -h
               total        used        free      shared  buff/cache   available
Mem:            11Gi        10Gi       522Mi       1.1Gi       2.3Gi       1.3Gi
Swap:          3.9Gi          0B       3.9Gi

According to your output you have 11G of RAM, and you are currently using almost 10G of it.
Also your SWAP is just under 4G, and you arent using any of it.
So that tells me a few things …

  • No, it is not enough memory - you are currently just about maxing it out, and I assume its not because posting here is your heaviest workload.
  • Your SWAP is pretty small, but its also not being engaged in a reasonable way. If you are using 90%+ of your available memory … some SWAP should be used. So beyond the size you may want to check other settings because it doesnt seem to be being used, at least not as much as I would think it should be.
1 Like

The cpu is also maxed out. So you are running your system at full load memory and cpu wise. No wonder that it feels slow. What are you doing if not a secret? Crypto? Transcoding video?

1 Like

Thanks! I will add more storage for my swap partition incase my firefox spikes my cpu and memory again. I will make it 6GB each distro installed on my drive. The reason I get those output because of firefox. I don’t know why firefox spikes my memory even though I only use a few tabs open. I just killall firefox whenever it spikes.

About my output, maybe its just a coincidence that time, the cpu and memory are spiking. The only thing that spikes those two is when I’m using firefox that’s the only thing.

I’m using two workspace, first workspace I have one window of firefox with one tab open constantly because its my facebook messenger chat tab. It’s on my extended monitor. Then my main monitor also have one window of firefox with mostly two to three tabs open, my second workspace have firefox windows opened too but only a fewer tabs are opened.

Most of the time my cpu and memory never goes up 50%, I don’t know sometimes when firefox is opened too long like more than a day or week, these cpu and memory are spiking. I just do killall firefox when that happens.

I don’t do crypto even if I want to learn about it though. Just using my laptop for learning to program or watch anime.

Thanks for the tip! Will try to add more swap maybe 6GB? since my overall memory is 12GB. I don’t know if its enough though.

You might hate to do this but …
(after closing all firefox instances)

firefox --safe-mode

And see how it works.
Just because firefox should not act like this and 90%+ of the time it is down to user configuration, the majority of that time due to bad extensions.

1 Like

Thanks, will try that and also disable my extensions one by one to identify what’s causing the spikes. :slight_smile:

Your inxi output suggests it is not a spike, since average cpu equals max cpu and the temperature and fans are also hight.

At that point i also think it is extension. Maybe you ARE cryptomining, you just do not know it :wink:

I only use the following extensions:

Adblock Plus - free ad blocker
SponsorBlock for Youtube - Skip Sponsorships
Dark Reader
YouTube NonStop
Browsec VPN - Free VPN For Firefox(only this using like once per three months or less, if necessary)
AdBlocker Ultimate
Save webP as PNG or JPEG(only active when I visit a webP page)

I don’t know if any of these are secretly mining on my computer causing my cpu and memory to spike. I don’t know how to mine any crypto, my laptop’s hardware specs are incapable of that. Hmmm :thinking:

From any distance I can still say this:
Neither of these are top-of-their-class adblockers,
And one should never need or use more than one adblock extension at a time.


IMHO, remove them all and install only uBlock Origin from Raymond Hill


That is the correct answer for browser extensions generally.
Some people have some good things to say about certain subscription services, but I dont really count those.
Another thing to mention is that ublock:origin has the same/better capabilities of other tools like noscript, so those can be considered redundant as well.
I also like to shape my hosts file - hblock can combine and sort multiple lists for this.
(note that the default of the big browsers is to use their own DNS services … so unless you change that your hosts file will be ignored)

1 Like