Can't install, run, find Conky


I thought I installed Conky via
sudo pacman -S conky
It seems it was installed. Then I run it but when I left-click Conky panel (default black coloured where I can see my cpu, ram etc.) it disappears after 1 second. It was strange.
After that I tried to find my installation path and conky.conf file but I couldn’t find. I searched online and learnt it must be whether ./config, ./local, /etc/. But I couldn’t find.

Isn’t it strange I couldn’t find installation folder but Conky works even it disappears after clicking.

Any help is appreciated.

EDIT: Here is what console answers my conky command:

[natali@bilgisayar ~]$ conky
conky: no personal or system-wide config file found, using builtin default
conky: desktop window (120003b) is subwindow of root window (6c2)
conky: window type - desktop
conky: drawing to created window (0x4000001)
conky: drawing to double buffer

1 Like

conky is installed as /usr/bin/conky. The user configurations go to ~/.conkyrc. Try starting conky from the terminal, and see if it prints any errors.

1 Like

@pobrn Thank you. I checked ~/.conkyrc but I couldn’t find it. It is weird.

It won’t be created automatically, you need to create it.

1 Like

@pobrn It is interesting. Thank you. When I type conky, the console answer this:

[natali@bilgisayar ~]$ conky
conky: no personal or system-wide config file found, using builtin default
conky: desktop window (120003b) is subwindow of root window (6c2)
conky: window type - desktop
conky: drawing to created window (0x4000001)
conky: drawing to double buffer

I have a conky.conf file from my previous setups. Should I create a folder and put conky.conf in it or… I’m confused. Can you elaborate a bit please?

Your conky configuration should be wherever it was in your previous setup, I guess.

  • Conky is a great tool for the advanced user as it allows you to create a monitoring system specific to your setup
  • Conky is a lousy tool for the beginning user as there is no “standard” way to set up Conky and it’s not meant to be.

If you’re a beginning user (cannot program, are not a wiz at bash, cannot cope with -- and # comments,in the same config file depending on the section) please stop reading now however if you’re an advanced user:

  • If you just want text, pamac install conky will do.

  • If you want graphics and use lua to create your own graphics circles / rings / progress bars / … or use an existing conky library to perform these feats, you need to pamac install conky-cairo

  • a personal conky.conf goes into ~/.config/conky/,

  • In the past config files used to go in ~/.conkyrc but the old Conky config files need a translation phase to be able to work on the newer versions of Conky and the translation is not 100% perfect so you need to know both the old and new system.

  • a system-wide conky.conf goes into /etc/conky/

  • The Wiki can be found here

  • This Conky output:

    needs this conky.conf:

    conky.config =
      console_bar_fill   = '»',
      console_bar_unfill = ' ',
      alignment = 'top_left',
      background = false,
      border_width = 2,
      cpu_avg_samples = 2,
      -- define Manjaro colours:
      default_color = '#1abc9c',  -- Same HTML as current terminal
      color1 = '#709080',         -- Kakhi
      color2 = '#dca3a3',         -- Salmon
      color3 = '#72d5a3',         -- Light Green
      color4 = '#f0dfaf',         -- Yellow
      color5 = '#7eb2e6',         -- Metal blue
      color6 = '#a45ec1',         -- Light aubergine
      font   = 'Envy Code R:bold:size=8',
      default_outline_color = '#1abc9c',  -- Same HTML as current terminal
      default_shade_color = '#1abc9c',  -- Same HTML as current terminal
      double_buffer = true,
      draw_borders = false,
      draw_graph_borders = true,
      draw_outline = false,
      draw_shades = false,
      extra_newline = false,
      gap_x = 25,
      gap_y = 25,
      minimum_height = 200,
      minimum_width = 200,
      net_avg_samples = 2,
      no_buffers = true,
      out_to_console = false,
      out_to_ncurses = false,
      out_to_stderr = false,
      out_to_x = true,
      own_window = true,
      own_window_class = 'Conky',
      own_window_type = 'normal',
      own_window_transparent = false,
      -- set transparency:
      own_window_argb_visual = true, own_window_argb_value = 100,
      show_graph_range = false,
      show_graph_scale = false,
      stippled_borders = 0,
      update_interval = 2.0,
      uppercase = false,
      use_spacer = 'none',
      use_xft = true,
      lua_load = '~/.config/conky/MyFunctions.lua',
      lua_draw_hook_post = "main",
    conky.text = [[
    ${color}Info:${color1} ${scroll 32 $nodename $kernel}
    ${color}Uptime    :${color1} $uptime
    ${color}Frequency :${color1} $freq ${color}MHz
    #${color}RAM Usage :${color1} ${lua conky_RoundUp ${mem} }/${lua conky_RoundUp ${memmax} } ${membar 4}
    ${color}RAM Usage :${color1} ${mem}/${memmax} ${membar 4}
    #${color}Swap Usage:${color1} ${lua conky_RoundUp ${swap} }/${lua conky_RoundUp ${swapmax} } ${swapbar 4}
    ${color}Swap Usage:${color1} ${swap}/${swapmax} ${swapbar 4}
    ${color}CPU Usage :${color1} $cpu% ${cpubar 4}
    ${color}Processes :${color1} $processes  ${color}Load:${color1} $loadavg
    ${color}Name                 CPU%   MEM%   PID
    ${color1} ${top name 1} ${color2} ${top cpu 1} ${top mem 1} ${top pid 1}
    ${color1} ${top name 2} ${color2} ${top cpu 2} ${top mem 2} ${top pid 2}
    ${color1} ${top name 3} ${color2} ${top cpu 3} ${top mem 3} ${top pid 3}
    ${color1} ${top name 4} ${color2} ${top cpu 4} ${top mem 4} ${top pid 4}
    ${color}File systems:
    ${color} /           ${color1}${fs_used /}/${fs_size /} ${fs_bar 6 /}
    ${color} /home       ${color1}${fs_used /home}/${fs_size /home} ${fs_bar 6 /home}
    ${color} /media/Data ${color1}${fs_used /media/Data}/${fs_size /media/Data} ${fs_bar 6 /media/Data}\
    # Don't show NAS if not mounted
    ${if_existing /media/NAS/home/}
    ${color} /media/NAS  ${color1}${fs_used /media/NAS}/${fs_size /media/NAS} ${fs_bar 6 /media/NAS}${endif}
    # Networking section will not show anything if no NICS are up
    # Will show speed and graph per NIC if they are up
    ${if_existing /sys/class/net/enp3s0/operstate up}${color}Ethernet
    ${color}Down: ${color1}${downspeed enp3s0}s ${alignr}${color}Up: ${color1}${upspeed enp3s0}/s
    ${downspeedgraph enp3s0 50,200 dca3a3 ffffff -l -t} ${alignr}${color1}${upspeedgraph enp3s0 50,200 dca3a3 ffffff -l -t}
    ${color}Total: ${color1}${totaldown enp3s0} ${alignr}${color}Total: ${color1}${totalup enp3s0}
    ${endif}${if_existing /sys/class/net/wlp2s0/operstate up}${color}WiFi
    ${color}Down: ${color1}${downspeed wlp2s0}/s ${alignr}${color}${color}Up: ${color1}${upspeed wlp2s0}/s
    ${downspeedgraph wlp2s0 50,200 dddddd ffffff -l -t} ${alignr}${color1}${upspeedgraph wlp2s0 50,200 dddddd ffffff -l -t}
    ${color}Total: ${color1}${totaldown wlp2s0} ${alignr}${color}Total: ${color1}${totalup wlp2s0}${endif}
    ${color} ISA     ${color1}${exec sensors | awk ' /Package/ {print $4}'}${alignr}${alignr}${color}CPU     ${color1}${exec sensors      | grep 'Core 0'                   | awk '{print $3}'}
    ${color} ACPI    ${color1}${exec sensors | grep --after-context=2 'acpitz' | awk 'FNR ==3 {print $2}'}${alignr}${color}WiFi    ${color1}${exec sensors | grep --after-context=2 'ath10k' | awk 'FNR ==3 {print $2}'}
    ${color} GPU     ${color1}+${exec nvidia-settings --query=gpucoretemp 2>/dev/null | grep 'GPUCoreTemp' | grep "\[gpu:0\]" | awk '{print $4}'}0°C
    ${color} SSD     ${color1}+${hddtemp /dev/sda}.0°C${alignr}${color}HDD     ${color1}+${hddtemp /dev/sda}.0°C
    ${color2}${execgraph "sensors | grep 'Core 0' | awk '{print $3}' | cut -b2,3"}

    But as you can see, this will not work on your system as you don’t have the /media/Data and NAS on your system and your WiFi and Ethernet are probably not called wlp2s0, and enp3s0 respectively without even talking about the exec sensors | grep --after-context=2 'acpitz' | awk 'FNR ==3 {print $2} so the above file without adaptation will just perform nothing as it’ll probably crash Conky.

If you’re a beginning user and you’ve read this far and exec nvidia-settings --query=gpucoretemp 2>/dev/null | grep 'GPUCoreTemp' | grep "\[gpu:0\]" | awk '{print $4}' means nothing to you, Conky is not for you.




To be honest: I was not expecting you to give me the Solution :exclamation:

So now you’ve piqued my curiosity: Are you:

  • busy reading the wiki
  • saying “Meh!” and moving onto something else

:question: :thinking:

1 Like



1 Like

As you said I created a folder and put my config. file into it. Then it worked.
I chose your reply as answer because it contains a lot of information about conky. I don’t think I’m a beginner or advanced user. Beside that “beginner” contains a broad of spectrum. But I know that I used Conky without any problem before on other distros such as Ubuntu and OpenSUSE. I didn’t read wiki because it used be easy and without any problem.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.