Can't install RStudio in any way


I had some problem with updates. When I was trying to update the laptop would either freeze or shut off. Finally, I looked into it and it was an issue of orphans, dependencies and version conflicting. I solved everything except RStudio.
I tried uninstalling it to reinstall, but I can’t reinstall it.
I tried with pamac to install rstudio-desktop, rstudio-desktop-git and rstudio-desktop-bin.
Every time it either aborts or the laptop shuts off.
I refreshed my mirrors and tried again.

sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

I tried to install it from a tarball downloaded from the official rstudio website, but only a blank space with buttons not working appears.
Finally, I installed yay and tried installing with it. Same issue.

  Kernel: 5.15.36-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=a2516510-96ae-4a13-ba0c-413ba8b9a795 rw quiet
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 5570 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0DRPKR v: X07 serial: <superuser required> UEFI: Dell
    v: 1.0.0 date: 08/07/2017
  ID-1: BAT0 charge: 31.4 Wh (100.0%) condition: 31.4/42.0 Wh (74.8%)
    volts: 12.8 min: 11.4 model: SMP DELL Y3F7Y6B type: Li-ion serial: <filter>
    status: full
  Device-1: hidpp_battery_5 model: Logitech MX Keys Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 7.54 GiB used: 3.55 GiB (47.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 797 high: 800 min/max: 400/3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 790 2: 797 3: 800 4: 792
    5: 800 6: 800 7: 800 8: 800 bogomips: 28808
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep sgx
    smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
    xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel ports:
    active: HDMI-A-1,eDP-1 empty: DP-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:5917 class-ID: 0300
  Device-2: AMD Topaz XT [Radeon R7 M260/M265 / M340/M360 M440/M445 530/535
    620/625 Mobile]
    vendor: Dell driver: amdgpu v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 4 link-max: gen: 3 speed: 8 GT/s lanes: 8 bus-ID: 01:00.0
    chip-ID: 1002:6900 class-ID: 0380
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:4 chip-ID: 0c45:6a06 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver: X:
    loaded: amdgpu,modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x318mm (20.00x12.52")
    s-diag: 599mm (23.6")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary model: HP LA2405x
    serial: <filter> built: 2013 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 518x324mm (20.39x12.76") diag: 611mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 640x480
  Monitor-2: eDP-1 pos: primary model: BOE Display 0x06a9 built: 2015
    res: 1680x1050 dpi: 124 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.36-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Dell driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-7:6
    chip-ID: 0cf3:e009 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 34 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
  Message: No logical block device data found.
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: f060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 238.47 GiB used: 149.3 GiB (62.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SK Hynix model: SC311 SATA 256GB
    size: 238.47 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0P10 scheme: GPT
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD+-RW GU90N rev: A1C2
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%)
    used: 149.3 GiB (64.0%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: a2516510-96ae-4a13-ba0c-413ba8b9a795
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: F8AA-DE62
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:77 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-2: 1-2:80 info: Logitech USB Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 046d:c06a class-ID: 0301
  Device-3: 1-3:81 info: Dell Keyboard SK-8115 type: Keyboard
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 70mA chip-ID: 413c:2003 class-ID: 0301
  Device-4: 1-5:4 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:6a06 class-ID: 0e02
  Device-5: 1-6:5 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Device-6: 1-7:6 info: Qualcomm Atheros type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 0cf3:e009
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 50.0 C pch: 47.0 C mobo: 44.0 C sodimm: SODIMM C
    gpu: amdgpu temp: 49.0 C
  Fan Speeds (RPM): cpu: 2802
  Processes: 283 Uptime: 12d 3h 32m wakeups: 353 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1598
  lib: 343 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.15
pamac install rstudio-desktop-git
Warning: rstudio-desktop-git is only available from AUR
Cloning rstudio-desktop-git build files...
Generating rstudio-desktop-git information...
Checking rstudio-desktop-git dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  rstudio-desktop-git  1.4.1103.r736-1    AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Building rstudio-desktop-git...
==> Making package: rstudio-desktop-git 1.4.1103.r736-1 (Di 10 Mai 2022 15:26:46 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating rstudio git repo...
Fetching origin
  -> Found
  -> Found
  -> Found qt.conf
  -> Found cran_multithread.patch
  -> Found nodejs-external.patch
==> Validating source files with sha256sums...
    rstudio ... Skipped ... Passed ... Passed
    qt.conf ... Passed
    cran_multithread.patch ... Passed
    nodejs-external.patch ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of rstudio git repo...
Cloning into 'rstudio'...
Updating files: 100% (8447/8447), done.
  -> Extracting with bsdtar
==> Starting prepare()...
Checking patch src/gwt/build.xml...
error: while searching for:

   <!-- panmirror typescript library -->
   <property name="node.version" value="10.19.0"/>
   <property name="node.dir" value="../../dependencies/common/node/${node.version}"/>
   <condition property="node.bin" value="../../../${node.dir}/bin/node">
        <os family="windows" />
   <condition property="node.bin" value="${node.dir}/node.exe">
     <os family="windows" />

   <!-- use node from /opt/rstudio-tools if installed (typical for Docker) -->

   <property name="panmirror.dir" value="./panmirror/src/editor"/>
   <property name="" value="./www/js/panmirror"/>

error: patch failed: src/gwt/build.xml:82
error: src/gwt/build.xml: patch does not apply
==> ERROR: A failure occurred in prepare().

Is there a specific requirement for you to install the git version? If yes then you cannot install this package right now as the maintainer is having a hard time fixing it:

Better install rstudio-desktop-bin:

pamac install  rstudio-desktop-bin

Thanks @ishaan2479 ,
I tried already, but at best I obtain a blank window with unresponsive buttons .
If I run

pamac checkupdates -a
Your system is up to date.

Out of Date:
rstudio-desktop-bin  2022.02.1.461-1  AUR

but it doesn’t provide a source for updating and several dependencies appear in orphans (pamac list -o).

This means it has been flagged as out-of-date on the AUR but the maintainer has not yet updated the PKGBUILD

Does it mean that whatever build I choose, they’re not working themselves.
It’s not my issue?

I don’t use RStudio myself but looking at the comments on the AUR it appears there are some issues. It has been suggested to run it from the terminal with rstudio-bin --no-sandbox

See comments at AUR (en) - rstudio-desktop-bin