Can't install ROS

Attempts to install package ros-noetic-desktop-full through pamac or yay end in failure. Pamac can’t find ogre 1.9, which exists. yay couldn’t find a lot of stuff.

I tried installing various versions of ogre through pamac. Regardless of the version I select, incuding 1.9, I get an error “target not found ogre-1.9”.

Any suggestions.
I am running kde plasma.

Build/install gazebo AUR package first and edit the PKGBUILD and replace ogre-1.9 with ogre (it will pull the one from repositories and the gazebo will then continue compiling with all the dependencies packages. It will take a while … Once is done, reboot and install ros-noetic-desktop-full

In theory that should work, but i could not let all build/compile …


That’s doing ROS is building. It’s taking a while and my laptop shut itself off once, but it’s heading in the right direction. :+1:

Then use makepkg directly. If that still doesn’t work, then report the issue on the corresponding AUR package page so the maintainer can fix it.


That’s a bit worrying, but that’s a subject for another topic.

It’s just a cheapo thinkpad, Low tier. I don’t think the intended use case was ever to run the CPU at 100 for a couple of hours. It never happened before. Hopefully it doesn’t become a recurring issue. The back cover also deformed a little.

Anyway, I knocked the cpu governor back to powersave and it completed successfully and at reasonable temps. Slow and steady as they say.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.