Can't install packages using pamac or pacman

Whenever I try to install any packages using pacman or pamac it throws weird errors at me and don’t install them :frowning:. Here are some examples:

when I tried to install “kaku”:
could not satisfy dependencies:

  • unable to satisfy dependency ‘gconf’ required by kaku-bin
    (I know this might mean I need to install a package called “gconf”, but that doesn’t work either)

invalid or corrupted database

remove_authorization: Timeout was reached

This one I typed out the terminal: sudo pacman -S aspell-en libmythes mythes-en languagetool

Error: failed retrieving file ‘languagetool-5.0-1-any.pkg.tar.xz’ from [can’t-include-link-so-this-the-replacment] : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

another one I tried to install from pamac: ttf-ms-fonts

get_authorization: Timeout was reached

I think this might be due to some problems with my internet connection, cause it started happening ever since my internet was being a bit bad, but right now my internet is working well enough for me to watch YouTube without much problems, so I don’t know why this issue is still persisting? would like some help from you guys, thank you <3

There was a couple of similar posts in the telegram group today. There was an issue with the AUR repos, are the apps from the AUR or official repos

1 Like

kaku-bin is from the AUR, the rest though should have been from the official repos. @NeoKovacs have you tried updating your mirrors?

1 Like

Try updating your mirrors:

sudo pacman-mirrors -f 0

You should always do sudo pacman -Syu to be safe when installing a package.

1 Like

I updated my mirror and tried installing that “spelling stuff” (with -Syu of course), same exact set of error messages! maybe it IS my internet? but YouTube is working so well and I’m able to use this site fine, don’t know what’s going on

strange, pacman find tar.XZ and not .zst … too old pacman ?

1 Like

yes, same error

Syyu because of background timer pamac-mirrorlist that sorts mirrors.
And … especially after running your command … it must be -Syyu (2 ys) to force db refresh.


sudo pacman-mirrors -f && sudo pacman -Syyu

What happens?


pacman works now, I can install packages using it, but pamac still keeps giving me remove_authorization: Timeout was reached and get_authorization: Timeout was reached :frowning:

actually pamac works now too, all I had to do was refresh the database, by the way I did try doing that yesterday, MANY times did not work, but today it works, so pacman and pamac are both working and it’s probably WAS just a Internet connection issue, very so for the inconvenience guys.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.