Can't install nvidia-settings

I’ve been trying to get lutris running league of legends for a few hours now. When I run it, it tells me to get Vulkan. I’ve been following a guide and ran into an issue.

Warning: Please ensure your graphics card is supported by modern Nvidia driver before installing. For a list of supported GPUs click here:

Proprietary driver and support for Vulkan are required for proper functionality of games.
To install it, execute following command:

sudo pacman -S nvidia-dkms nvidia-utils lib32-nvidia-utils nvidia-settings vulkan-icd-loader lib32-vulkan-icd-loader

When I execute the command I get this:

[sh0tz@sh0tzPC ~]$ sudo pacman -S nvidia-dkms nvidia-utils lib32-nvidia-utils nvidia-settings vulkan-icd-loader lib32-vulkan-icd-loader
warning: nvidia-utils-470.57.02-1 is up to date -- reinstalling
error: target not found: nvidia-settings
warning: vulkan-icd-loader-1.2.185-1 is up to date -- reinstalling
warning: lib32-vulkan-icd-loader-1.2.184-1 is up to date -- reinstalling

So the error is:

error: target not found: nvidia-settings

I have no idea what to do now. I tried googleing a bit, but no result helped
Here’s the guide link: docs/ at master · lutris/docs · GitHub

Nvidia drivers in Manjaro are installed via MHWD, and during install, the scripts will also install nvidia-utils that already has nvidia-settings
There is no such nvidia-settings separate package.

You don’t need that, unless you run a custom kernel without the precompiled nvidia modules.

Please share:
inxi -Fazy
mhwd -li

[sh0tz@sh0tzPC ~]$ inxi -Fazy
  Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=f871d4e7-4ba7-461a-8fa9-d0517e30090a rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASRock model: H110M-DGS serial: <filter> 
  UEFI: American Megatrends v: P1.40 date: 01/25/2016 
  Info: Quad Core model: Intel Core i5-6402P bits: 64 type: MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: EA cache: 
  L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 22408 
  Speed: 800 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: Gigabyte driver: nouveau 
  v: kernel bus-ID: 01:00.0 chip-ID: 10de:1402 class-ID: 0300 
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 1-7:4 chip-ID: 046d:0825 class-ID: 0102 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
  display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") 
  s-diag: 1055mm (41.5") 
  Monitor-1: DP-1 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  Monitor-2: DVI-D-1 res: 1920x1080 hz: 60 dpi: 92 
  size: 531x299mm (20.9x11.8") diag: 609mm (24") 
  OpenGL: renderer: NV126 v: 4.3 Mesa 21.1.6 direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 
  class-ID: 0403 
  Device-2: NVIDIA GM206 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fba 
  class-ID: 0403 
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 1-7:4 chip-ID: 046d:0825 class-ID: 0102 serial: <filter> 
  Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: d000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: D-Link GO-USB-N150 N Adapter type: USB driver: r8188eu 
  bus-ID: 1-6:3 chip-ID: 2001:3311 class-ID: 0000 serial: <filter> 
  IF: wlp0s20f0u6 state: up mac: <filter> 
  Local Storage: total: 1.02 TiB used: 23.34 GiB (2.2%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SHFS37A120G 
  size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: BBF0 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA100 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: A750 scheme: GPT 
  ID-1: / raw-size: 111.49 GiB size: 109.18 GiB (97.93%) 
  used: 23.34 GiB (21.4%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Alert: No swap data was found. 
  System Temperatures: cpu: 38.0 C mobo: N/A gpu: nouveau temp: 39.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1155 
  Processes: 219 Uptime: 1h 0m wakeups: 1 Memory: 7.73 GiB used: 2 GiB (25.9%) 
  Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 Packages: 1211 
  pacman: 1203 lib: 380 flatpak: 0 snap: 8 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.06 
[sh0tz@sh0tzPC ~]$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

It looks like you have nouveau/free drivers installed which won’t have vulkan. The easiest option is to open manjaro settings go to hardware configuration and install the nvidia drivers there using the gui. You can also do it using cli and mhwd

1 Like

As stated above, you run nouveau drivers. Remove them like this from terminal:
sudo mhwd -r pci video-linux
Install the nvidia proprietary drivers:
sudo mhwd -i pci video-nvidia
Reboot and test your games.