Can't install nvidia prime driver & intel driver using mhwd by cli or gui

hello ,

i have a problem with the installation of nvidia prime driver ( and the same occurs with intel driver)

i noticed this strange behavior in my terminal

when i put yes to continue the installation of nvidia prime

this happens:

mhwd -f -i pci video-hybrid-intel-nvidia-450xx-prime

Dependencies to install: video-modesetting
Proceed with installation? [Y/n]

then nothing happens …

i tried to put --all --yes or -y but it was unsuccessful…

in the hardware detection tool it gets stucked with Proceed with installation? [Y/n]

so what should i do ?

i have an optimus laptop…

this is the output of inxi --FZ

`System: Host: noah-PC Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 Console: tty 1 Distro: Manjaro Linux
Machine: Type: Laptop System: HP product: HP Pavilion Notebook

Mobo: HP model: 84F8 v: 08.10 serial: PHNEF018JBK089 UEFI: AMI v: F.18 date: 06/20/2018

Battery: ID-1: BAT0 charge: 44.2 Wh condition: 52.7/52.7 Wh (100%)

CPU: Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP L2 cache: 8192 KiB
Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800

Graphics: Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nouveau v: kernel
Device-3: Chicony HP Wide Vision HD type: USB driver: uvcvideo
Display: server: X.Org 1.20.8 driver: intel,nouveau unloaded: modesetting resolution: 1920x1080~60Hz

OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.5

Audio: Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel

Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel

Sound Server: ALSA v: k5.8.1-3-MANJARO

Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
IF: eno1 state: down
Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter driver: rtw_8822be
IF: wlo1 state: up

Drives: Local Storage: total: 1.03 TiB used: 49.07 GiB (4.7%)
ID-1: /dev/sda vendor: SanDisk model: SD9SN8W-128G-1006 size: 119.24 GiB
ID-2: /dev/sdb vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB
RAID: Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci

Partition: ID-1: / size: 103.03 GiB used: 9.98 GiB (9.7%) fs: ext4 dev: /dev/sda2
ID-2: /home size: 905.97 GiB used: 39.08 GiB (4.3%) fs: ext4 dev: /dev/sdb1

Swap: ID-1: swap-1 type: partition size: 3.81 GiB used: 0 KiB (0.0%) dev: /dev/sda1

Sensors: System Temperatures: cpu: 39.0 C mobo: N/A gpu: nouveau temp: 34 C
Fan Speeds (RPM): N/A

Info: Processes: 238 Uptime: 52m Memory: 7.63 GiB used: 1.14 GiB (14.9%) Shell: Bash inxi: 3.1.05 `

thank you so much

1 Like


Please use the search function in the top-right.

You would probably find what you are looking for, such as these:

Or any one of the other threads.


Thanks. This solved my problem.

First install the video-modesetting dependency manually using :
sudo mhwd -i pci video-modesetting
then, install the required drivers using:
sudo mhwd -a pci nonfree 0300
or use:
sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime
This Worked fine for me!
Hope it works for you!
Would be curious to know what happened with you!!