Can't install nonfree drivers with mhwd

Hi Newbie here,

i have a laptop with an intergrated intel gpu and an discrete nvidia gpu and managed to install manjaro-i3 from the community tab
During installation i choose non-free drivers but running mhwd -li shows that i have the freedrivers installed.
I tried to uninstall them and use sudo mhwd -a pci nonfree 0300 but somehow it only installs video-linux and mhwd still has the free drivers installed.

I also tried to install the drivers via manjaro-settings-manager, under “Hardware Configuration” i can only see free drivers.

My end goal is to use optimus-manager to switch between both gpus.

thanks in adanvance

You always have the free drivers installed no matter what, it’s built into the kernel.

You’d want to choose the hybrid drivers for your computer in MHWD.

1 Like

Could you post the outputs of mhwd -l and inxi -Gxx ?

mhwd -l 
> 0000:58:00.0 (0302:10de:1f95) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


> m0000:00:02.0 (0300:8086:8a52) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI
inxi -Gxx
Graphics:  Device-1: Intel Iris Plus Graphics G7 vendor: Razer USA driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:8a52 
           Device-2: NVIDIA vendor: Razer USA driver: nouveau v: kernel bus ID: 58:00.0 
           chip ID: 10de:1f95 
           Display: x11 server: X.Org 1.20.8 driver: intel,modesetting,nouveau 
           alternate: fbdev,nv,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.7 compat-v: 3.1 
           direct render: Yes 

thanks for your response

Ahh that explains it. The hardware detection cannot correctly detect you Nvidia card since no model is listed. You would need to find out which model is in the laptop and either force install the drivers or install manually.
With mhwd -la you can find out the names of all theoretically available configs.

oh ok- Nvidias site recommends the version 450.57 which is not listed and if i recall correctly is subject to another forum post here.
Is it possible to download a driver from the offical nvidia driver page with the option operating system set to Linux 64-Bit and install it manually?
Or would you advise to wait until the 450 driver is part of the offical manjaro ?

With the driver you should wait until it is in the repos. Otherwise you will not get updates for them.
If your nvidia card is supported by the 450 series of drivers though you should be able to use it with the 440 series.
You should be able to install the drivers with this command:
mhwd -f -i pci video-hybrid-intel-nvidia-440xx-prime
Not sure though if the -f for forcing it is really necessary though.

sorry to bother you again.
I managed to install the driver after updating my system with pacman -Syu. Afterwards i installed the optimus-manager package. I don’t have any custom xorg.conf and /etc/X11/xorg.conf.d/90-mhwd.conf only contained a comment. Also i don’t have any gpu monitoring apps (as far as i know).
After rebooting i get an error that stops booting failed to start light display manager. After searching the web i found that i can get a tty with ctrl+alt+f2.
Do you have an idea how to solve the error or a clue how to boot into the system again?
100x thanks in advance

The optimus manager can sometimes be problematic. Personally i would recommend removing it and reinstalling the driver. After that i would recommend making a backup before trying to install optimus manager again.
I’m not absolutely sure how to proceed though since i never used the optimus manager before and don’t exactly know which configs might have been overwritten.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.